GHSA-8396-jffm-qx4w CVE-2026-48096 GO-2026-5239
OpenFGA has cache-key delimiter injection in shared-iterator and v2 iterator that caches enables intra-store authorization-decision poisoning
- Severity
- 5.0 / 10
- Medium · CVSS 3.1
- Exploit chance (EPSS)
- 0.10%
- Chance of exploitation in the next 30 days. Higher than 0.88% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- CWE-345 Insufficient Verification of Data Authenticity
- CWE-668 Exposure of Resource to Wrong Sphere
- Fix
1.16.0- Upgrade github.com/openfga/openfga to this version or later
Description
Description
In OpenFGA, when iterator caching is enabled, two distinct check requests can produce the same cache key, leading to OpenFGA reusing an earlier cached result for a subsequent request.
Preconditions
This applies if the following preconditions are present:
- FGA runs with SharedIteratorCache enabled,
- FGA runs with ListObjectsIteratorCache enabled.
Fix
Upgrade to version 1.16.0 or greater.
Acknowledgements
OpenFGA would like to thank @j4xT for the discovery and the detailed report.
Affected versions
Go
| Package | Vulnerable | Fixed in |
|---|---|---|
| github.com/openfga/openfga | < 1.16.0 |
1.16.0 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
github.com/openfga/openfga Go → 1.16.0
- go
go get github.com/openfga/openfga@v1.16.0 && go mod tidy
Severity breakdown
CVSS 3.1 5.0
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:L
- Attack vector
- Network
- Attack complexity
- High
- Privileges required
- Low
- User interaction
- None
- Scope
- Unchanged
- Confidentiality
- Low
- Integrity
- Low
- Availability
- Low
Weakness
CWE-345: Insufficient Verification of Data Authenticity
The product does not sufficiently verify the origin or authenticity of data, in a way that causes it to accept invalid data.
CWE-668: Exposure of Resource to Wrong Sphere
The product exposes a resource to the wrong control sphere, providing unintended actors with inappropriate access to the resource.
References
Advisories
Packages
Other links
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-g3pg-frfm-pr2m OpenFGA: ListUsers returns a deliberately-excluded user when a `but not` exclusion under a type-bound wildcard is intersected (`and`) with another relation that also grants that user | Medium | Also affects github.com/openfga/openfga |
| GHSA-hcxc-wf8j-23hv OpenFGA: OIDC audience validation skipped when --authn-oidc-audience is unset | High | Also affects github.com/openfga/openfga |
| GHSA-cf98-j28v-49v6 OpenFGA Improper Policy Enforcement | Medium | Also affects github.com/openfga/openfga |
| GHSA-57j5-qwp2-vqp6 OpenFGA has Improper Policy Enforcement | Medium | Also affects github.com/openfga/openfga |
| GHSA-68m9-983m-f3v5 OpenFGA: Unauthenticated playground endpoint discloses preshared API key in HTML response | Medium | Also affects github.com/openfga/openfga |
| GHSA-jwvj-g8pc-cx45 OpenFGA's BatchCheck within-request deduplication produces incorrect authorization decisions via list-value cache-key collision | High | Also affects github.com/openfga/openfga |
| GHSA-h6c8-cww8-35hf OpenFGA has an Authorization Bypass through cached keys | Critical | Also affects github.com/openfga/openfga |
| GHSA-jq9f-gm9w-rwm9 OpenFGA Improper Policy Enforcement | High | Also affects github.com/openfga/openfga |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor