GHSA-7v94-64hj-m82h BIT-tensorflow-2021-41207 CVE-2021-41207 PYSEC-2021-399 PYSEC-2021-616 PYSEC-2021-814
FPE in `ParallelConcat`
- Severity
- 0.0 / 10
- Medium · CVSS 4.0
- Exploit chance (EPSS)
- 0.14%
- Chance of exploitation in the next 30 days. Higher than 3.38% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- CWE-369 Divide By Zero
- Fix
- Available
- 3 packages have a fixed version
Description
Impact
The implementation of ParallelConcat misses some input validation and can produce a division by 0:
import tensorflow as tf
@tf.function
def test():
y = tf.raw_ops.ParallelConcat(values=[['tf']],shape=0)
return y
test()
Patches
We have patched the issue in GitHub commit f2c3931113eaafe9ef558faaddd48e00a6606235.
The fix will be included in TensorFlow 2.7.0. We will also cherrypick this commit on TensorFlow 2.6.1, TensorFlow 2.5.2, and TensorFlow 2.4.4, as these are also affected and still in supported range.
For more information
Please consult our security guide for more information regarding the security model and how to contact us with issues and questions.
Attribution
This vulnerability has been reported by members of the Aivul Team from Qihoo 360.
Affected versions
PyPI
| Package | Vulnerable | Fixed in |
|---|---|---|
| tensorflow | >= 2.6.0, < 2.6.1 |
2.6.1 |
| tensorflow | >= 2.5.0, < 2.5.2 |
2.5.2 |
| tensorflow | < 2.4.4 |
2.4.4 |
| tensorflow | < 2.4.4>= 2.5.0, < 2.5.2>= 2.6.0, < 2.6.1>= 2.7.0rc0, < 2.7.0 |
2.4.42.5.22.6.12.7.0 |
| tensorflow-cpu | < 2.4.4 |
2.4.4 |
| tensorflow-cpu | >= 2.5.0, < 2.5.2 |
2.5.2 |
| tensorflow-cpu | >= 2.6.0, < 2.6.1 |
2.6.1 |
| tensorflow-cpu | < 2.4.4>= 2.5.0, < 2.5.2>= 2.6.0, < 2.6.1>= 2.7.0rc0, < 2.7.0 |
2.4.42.5.22.6.12.7.0 |
| tensorflow-gpu | < 2.4.4 |
2.4.4 |
| tensorflow-gpu | >= 2.5.0, < 2.5.2 |
2.5.2 |
| tensorflow-gpu | >= 2.6.0, < 2.6.1 |
2.6.1 |
| tensorflow-gpu | < 2.4.4>= 2.5.0, < 2.5.2>= 2.6.0, < 2.6.1>= 2.7.0rc0, < 2.7.0 |
2.4.42.5.22.6.12.7.0 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
tensorflow PyPI → 2.6.1
- pip
pip install --upgrade "tensorflow>=2.6.1"- poetry
poetry add "tensorflow>=2.6.1"- uv
uv add "tensorflow>=2.6.1"
tensorflow-cpu PyPI → 2.4.4
- pip
pip install --upgrade "tensorflow-cpu>=2.4.4"- poetry
poetry add "tensorflow-cpu>=2.4.4"- uv
uv add "tensorflow-cpu>=2.4.4"
tensorflow-gpu PyPI → 2.4.4
- pip
pip install --upgrade "tensorflow-gpu>=2.4.4"- poetry
poetry add "tensorflow-gpu>=2.4.4"- uv
uv add "tensorflow-gpu>=2.4.4"
Severity breakdown
CVSS 4.0 0.0
CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
- Attack vector
- Local
- Attack complexity
- Low
- Attack requirements
- None
- Privileges required
- Low
- User interaction
- None
- Confidentiality (vulnerable system)
- None
- Integrity (vulnerable system)
- None
- Availability (vulnerable system)
- High
- Confidentiality (subsequent systems)
- None
- Integrity (subsequent systems)
- None
- Availability (subsequent systems)
- None
CVSS 3.1 5.5
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- Attack vector
- Local
- Attack complexity
- Low
- Privileges required
- Low
- User interaction
- None
- Scope
- Unchanged
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Weakness
CWE-369: Divide By Zero
The product divides a value by zero.
References
Advisories
Packages
Other links
- github.com/tensorflow/tensorflow/security/advisories/GHSA-7v94-64hj-m82h
- github.com/tensorflow/tensorflow/commit/9de11bdc2cf1284b2f635419bd3e6bbc7643eb2c
- github.com/tensorflow/tensorflow/commit/d11f21bbdfa54f3576ae860fc927bf23c675ebc0
- github.com/tensorflow/tensorflow/commit/e67caccea81167402c62977b5c521f2a8b261d6a
- github.com/tensorflow/tensorflow/commit/f2c3931113eaafe9ef558faaddd48e00a6606235
- github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2021-616…
- github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2021-814…
- github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-399.yaml
- github.com/tensorflow/tensorflow/blob/8d72537c6abf5a44103b57b9c2e22c14f5f49698/…
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-gjh7-xx4r-x345 TensorFlow has segfault in array_ops.upper_bound | High | Also affects tensorflow |
| GHSA-fxgc-95xx-grvq TensorFlow Denial of Service vulnerability | Medium | Also affects tensorflow |
| GHSA-93vr-9q9m-pj8p TensorFlow vulnerable to Out-of-Bounds Read in DynamicStitch | High | Also affects tensorflow |
| GHSA-qjqc-vqcf-5qvj TensorFlow vulnerable to seg fault in `tf.raw_ops.Print` | High | Also affects tensorflow |
| GHSA-7jvm-xxmr-v5cw TensorFlow vulnerable to integer overflow in EditDistance | High | Also affects tensorflow |
| GHSA-64jg-wjww-7c5w TensorFlow has Null Pointer Error in TensorArrayConcatV2 | High | Also affects tensorflow |
| GHSA-6hg6-5c2q-7rcr TensorFlow has Heap-buffer-overflow in AvgPoolGrad | High | Also affects tensorflow |
| GHSA-558h-mq8x-7q9g TensorFlow has Null Pointer Error in SparseSparseMaximum | High | Also affects tensorflow |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor