Skip to content

GHSA-7v28-g2pq-ggg8

Ghost vulnerable to remote code execution in locale setting change

Medium npm
Severity
6.6 / 10
Medium · CVSS 3.1
Exploit chance (EPSS)
—
No score published
Known exploited
No
Not in CISA's catalog
Weakness
—
Not classified
Fix
4.48.2
Upgrade ghost to this version or later

Description

Impact

A vulnerability in an upstream library means an authenticated attacker can abuse locale input to execute arbitrary commands from a file that has previously been uploaded using the file upload functionality in the post editor.

Patches

Fixed in 5.2.3, all 5.x sites should update as soon as possible. Fixed in 4.48.2, all 4.x sites should update as soon as possible.

Workarounds

Patched versions of Ghost add validation to the locale input to prevent execution of arbitrary files. Updating Ghost is the quickest complete solution.

As a workaround, if for any reason you cannot update your Ghost instance, you can block the POST /ghost/api/admin/settings/ endpoint, which will also disable updating settings for your site.

For more information

If you have any questions or comments about this advisory:

Credits

Affected versions

npm

PackageVulnerableFixed in
ghost
< 4.48.2
4.48.2
ghost
>= 5.0.0, < 5.2.3
5.2.3

How to fix

Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.

ghost npm → 4.48.2

npm
npm install ghost@4.48.2
yarn
yarn add ghost@4.48.2
pnpm
pnpm add ghost@4.48.2

Severity breakdown

CVSS 3.1 6.6

CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:L/I:L/A:L

Attack vector
Network
Attack complexity
Low
Privileges required
High
User interaction
None
Scope
Changed
Confidentiality
Low
Integrity
Low
Availability
Low

References

Timeline

  1. Published
  2. Last updated by the source
AdvisorySeverityWhy it's related
GHSA-x3mg-q38v-m562
Ghost: Authorization Issue Allowed Author Role to Delete any Post
Medium Also affects ghost
GHSA-8575-cr6v-7jh4
Ghost: Stored XSS via SVG Uploads Bypassing Sanitization
High Also affects ghost
GHSA-r7f2-6fj8-6fg2
Ghost: Private IP Filtering Bypass via IPv6 Transition Addresses
Medium Also affects ghost
GHSA-322m-ff4g-9vx9
Ghost: Server-Side Request Forgery in Bookmark Fetching
Medium Also affects ghost
GHSA-fwh9-qg68-vxp4
Ghost: Regular Expression Denial of Service in Content Import
Medium Also affects ghost
GHSA-9m4w-fmjw-fvjq
Ghost: Regular Expression Denial of Service in External Media Inliner
Medium Also affects ghost
GHSA-hqq2-xqr2-fmx2
Ghost : Stored XSS via SVG Files in Content Imports
Medium Also affects ghost
GHSA-69qc-f5m6-889c
Ghost: Stored XSS via Embed Card Previews
High Also affects ghost
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor