GHSA-72f5-rr8c-r6gr BIT-fluentd-2026-44161 CVE-2026-44161
Fluentd is Vulnerable to Server-Side Request Forgery (SSRF) via Placeholder Expansion in `out_http`
- Severity
- 7.2 / 10
- High · CVSS 3.1
- Exploit chance (EPSS)
- 0.44%
- Chance of exploitation in the next 30 days. Higher than 38.41% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- CWE-918 Server-Side Request Forgery (SSRF)
- Fix
1.19.3- Upgrade fluentd to this version or later
Description
The out_http output plugin allows the use of placeholders (such as ${tag}) in the endpoint configuration parameter.
It was discovered that if the placeholder value is derived from untrusted user input, an attacker can maliciously control the destination hostname of the outbound HTTP requests made by Fluentd.
Impact
This vulnerability allows for a Server-Side Request Forgery (SSRF) attack.
An unauthenticated attacker can force the Fluentd node to send HTTP requests to arbitrary internal services. This can lead to unauthorized access to internal APIs, data exfiltration, or the compromise of cloud metadata endpoints (e.g., AWS IMDS 169.254.169.254).
Patches
v1.19.3
Workarounds
If an immediate upgrade is not possible, users are strongly advised to apply the following mitigations:
-
Avoid Dynamic Hostnames
- Do not use the placeholder in the endpoint parameter as hostname.
-
Restrict Network Access
- Use firewall rules (e.g., iptables, AWS Security Groups) to block the Fluentd node from accessing sensitive internal IP addresses, specifically the cloud provider's metadata service and other internal microservices that Fluentd does not explicitly need to access.
-
Restrict allowed hosts
- Inject filter to accept allowed hosts in placeholders explicitly if possible.
Affected versions
RubyGems
| Package | Vulnerable | Fixed in |
|---|---|---|
| fluentd | < 1.19.3 |
1.19.3 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
fluentd RubyGems → 1.19.3
- bundler
bundle update fluentd # Gemfile: gem "fluentd", ">= 1.19.3"
Severity breakdown
CVSS 3.1 7.2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:N/A:L
- Attack vector
- Network
- Attack complexity
- Low
- Privileges required
- None
- User interaction
- None
- Scope
- Changed
- Confidentiality
- Low
- Integrity
- None
- Availability
- Low
Weakness
CWE-918: Server-Side Request Forgery (SSRF)
The web server receives a URL or similar request from an upstream component and retrieves the contents of this URL, but it does not sufficiently ensure that the request is being sent to the expected destination.
References
Fixes and patches
Packages
Other links
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-j9cw-hwqf-85w7 Fluentd is Vulnerable to Denial of Service (DoS) via Gzip Decompression Bomb in `in_http` and `in_forward` | High | Also affects fluentd |
| GHSA-pr7j-96cj-549h Fluentd is Vulnerable to Exposure of Sensitive Information via Monitor Agent API | High | Also affects fluentd |
| GHSA-44hj-4m45-frj3 Fluentd is Vulnerable to Remote Code Execution (RCE) via Arbitrary File Write in `${tag}` Placeholder | Critical | Also affects fluentd |
| GHSA-fppq-mj76-fpj2 fluentd vulnerable to remote code execution due to insecure deserialization (in non-default configuration) | Low | Also affects fluentd |
| GHSA-5jrp-w8fr-mrww Fluentd Escape Sequence Injection Vulnerability | Critical | Also affects fluentd |
| GHSA-hwhf-64mh-r662 ReDoS vulnerability in parser_apache2 | Medium | Also affects fluentd |
| EEF-CVE-2026-115700 SSRF allowlist bypass via percent-encoded bracketed IPv6 or trailing-dot IP literal in hackney | Not rated yet | Same weakness, CWE-918 |
| GHSA-2wqp-q3c6-ccj5 MLflow: SSRF on unauthenticated MLflow servers via third-party scorer kwargs in the scorer invoke, register, and GenAI evaluate endpoints | Medium | Same weakness, CWE-918 |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor