Skip to content

GHSA-6x98-fx9j-7c78 CVE-2017-1000489

Disabled users able to log in with third party SSO plugin

High Packagist
Severity
8.1 / 10
High · CVSS 3.0
Exploit chance (EPSS)
1.12%
Chance of exploitation in the next 30 days. Higher than 66.08% of scored vulnerabilities.
Known exploited
No
Not in CISA's catalog
Weakness
CWE-287 Improper Authentication
Fix
2.12.0
Upgrade mautic/core to this version or later

Description

Impact

Mautic versions 2.0.0 - 2.11.0 with a SSO plugin installed could allow a disabled user to still login using email address

Patches

Upgrade to 2.12.0 or later.

Workarounds

None.

For more information

If you have any questions or comments about this advisory:

Affected versions

Packagist

PackageVulnerableFixed in
mautic/core
>= 2.0.0, < 2.12.0
2.12.0

How to fix

Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.

mautic/core Packagist → 2.12.0

composer
composer require mautic/core:^2.12.0

Severity breakdown

CVSS 3.0 8.1

CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Attack vector
Network
Attack complexity
High
Privileges required
None
User interaction
None
Scope
Unchanged
Confidentiality
High
Integrity
High
Availability
High

Weakness

CWE-287: Improper Authentication

When an actor claims to have a given identity, the product does not prove or insufficiently proves that the claim is correct.

How to prevent it
  • Architecture and Design: Use an authentication framework or library such as the OWASP ESAPI Authentication feature.

References

Timeline

  1. Published
  2. Last updated by the source
  3. Latest EPSS score
AdvisorySeverityWhy it's related
GHSA-5hvg-w58j-545m
Mautic has Stored Cross-Site Scripting (XSS) in Project Option Selector
Medium Also affects mautic/core
GHSA-7h65-whp7-rgqf
Mautic has Stored Cross-Site Scripting (XSS) in Projects Component
High Also affects mautic/core
GHSA-2jrw-c95w-h43g
Mautic has an Authorization Bypass in API v2 Endpoints
High Also affects mautic/core
GHSA-6r9h-4h75-7q4x
Mautic vulnerable to Path Traversal via Campaign Import
Critical Also affects mautic/core
GHSA-9fx4-7cmj-47vg
Mautic has Server-Side Template Injection (SSTI) in Theme Templates
Critical Also affects mautic/core
GHSA-jmv8-8j9j-rcpc
Mautic Focus component Vulnerable to SSRF
Medium Also affects mautic/core
GHSA-fcmw-wx57-9p75
Mautic has SQL Injection in API Contact Filtering
High Also affects mautic/core
GHSA-r5j5-q42h-fc93
Mautic is Vulnerable to SQL Injection through Contact Activity API Sorting
High Also affects mautic/core
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor