GHSA-6vfq-jmxg-g58r CVE-2022-36101
Shopware contains sensitive data in backend customer module
- Severity
- 5.4 / 10
- Medium · CVSS 3.1
- Exploit chance (EPSS)
- 0.70%
- Chance of exploitation in the next 30 days. Higher than 53.07% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- CWE-200 Exposure of Sensitive Information to an Unauthorized Actor
- CWE-312 Cleartext Storage of Sensitive Information
- Fix
5.7.15- Upgrade shopware/shopware to this version or later
Description
Impact
The request for the customer detail view in the backend administration contained sensitive data like the hashed password and the session ID.
Patches
We recommend updating to the current version 5.7.15. You can get the update to 5.7.15 regularly via the Auto-Updater or directly via the download overview. https://www.shopware.com/en/changelog-sw5/#5-7-15
For older versions you can use the Security Plugin: https://store.shopware.com/en/swag575294366635f/shopware-security-plugin.html
References
https://docs.shopware.com/en/shopware-5-en/security-updates/security-update-09-2022
Affected versions
Packagist
| Package | Vulnerable | Fixed in |
|---|---|---|
| shopware/shopware | < 5.7.15 |
5.7.15 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
shopware/shopware Packagist → 5.7.15
- composer
composer require shopware/shopware:^5.7.15
Severity breakdown
CVSS 3.1 5.4
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N
- Attack vector
- Network
- Attack complexity
- Low
- Privileges required
- None
- User interaction
- Required
- Scope
- Unchanged
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Weakness
CWE-200: Exposure of Sensitive Information to an Unauthorized Actor
The product exposes sensitive information to an actor that is not explicitly authorized to have access to that information.
How to prevent it
- Architecture and Design: Compartmentalize the system to have "safe" areas where trust boundaries can be unambiguously drawn. Do not allow sensitive data to go outside of the trust boundary and always be careful when interfacing with a compartment outside of the safe area. Ensure that appropriate compartmentalization is built into the system design, and the compartmentalization allows for and reinforces privilege separation functionality. Architects and designers should rely on the principle of least privilege to decide the appropriate time to use privileges and the time to drop privileges.
CWE-312: Cleartext Storage of Sensitive Information
The product stores sensitive information in cleartext within a resource that might be accessible to another control sphere.
How to prevent it
- Implementation, System Configuration, Operation: When storing data in the cloud (e.g., S3 buckets, Azure blobs, Google Cloud Storage, etc.), use the provider's controls to encrypt the data at rest. [REF-1297] [REF-1299] [REF-1301]
- Implementation, System Configuration, Operation: In some systems/environments such as cloud, the use of "double encryption" (at both the software and hardware layer) might be required, and the developer might be solely responsible for both layers, instead of shared responsibility with the administrator of the broader system/environment.
References
Advisories
Packages
Other links
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-7cw6-7h3h-v8pf Shopware Has Improper Control of Generation of Code in Twig rendered views | High | Also affects shopware/shopware |
| GHSA-6w82-v552-wjw2 Shopware Storefront Reflected XSS in Storefront Login Page | Medium | Also affects shopware/shopware |
| GHSA-9v82-vcjx-m76j Shopware: Reflective Cross Site-Scripting (XSS) in CMS components | High | Also affects shopware/shopware |
| GHSA-83jv-4prm-34g7 Shopware Remote Code Execution Vulnerability | Critical | Also affects shopware/shopware |
| GHSA-7336-ghhp-f2qj Shopware Remote Code Execution Vulnerability | Critical | Also affects shopware/shopware |
| GHSA-jqr7-5h7r-ch8p Shopware Non-Persistent XSS in the Frontend | Medium | Also affects shopware/shopware |
| GHSA-q3g4-2vw9-xv27 Shopware Remote Code Execution Vulnerability | Critical | Also affects shopware/shopware |
| GHSA-gh66-fp7j-98v5 Shopware improper mail validation vulnerability | Medium | Also affects shopware/shopware |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor