GHSA-6h8x-73fx-q2h9 CVE-2016-4043 PYSEC-2017-57
Chameleon in Plone allows Authentication Bypass
- Severity
- 0.0 / 10
- Medium · CVSS 4.0
- Exploit chance (EPSS)
- 1.01%
- Chance of exploitation in the next 30 days. Higher than 63.28% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- CWE-287 Improper Authentication
- Fix
5.1a2- Upgrade plone to this version or later
Description
Chameleon (five.pt) in Plone 5.0rc1 through 5.1a1 allows remote authenticated users to bypass Restricted Python by leveraging permissions to create or edit templates.
Affected versions
PyPI
| Package | Vulnerable | Fixed in |
|---|---|---|
| plone | >= 5.0rc1, <= 5.0.4 |
No fix yet |
| plone | 1 listed versions | No fix yet |
| plone | >= 5.0rc1, < 5.1a2 |
5.1a2 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
plone PyPI → 5.1a2
- pip
pip install --upgrade "plone>=5.1a2"- poetry
poetry add "plone>=5.1a2"- uv
uv add "plone>=5.1a2"
Severity breakdown
CVSS 4.0 0.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N
- Attack vector
- Network
- Attack complexity
- Low
- Attack requirements
- None
- Privileges required
- High
- User interaction
- None
- Confidentiality (vulnerable system)
- None
- Integrity (vulnerable system)
- High
- Availability (vulnerable system)
- None
- Confidentiality (subsequent systems)
- None
- Integrity (subsequent systems)
- None
- Availability (subsequent systems)
- None
CVSS 3.0 4.9
CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:H/A:N
- Attack vector
- Network
- Attack complexity
- Low
- Privileges required
- High
- User interaction
- None
- Scope
- Unchanged
- Confidentiality
- None
- Integrity
- High
- Availability
- None
Weakness
CWE-287: Improper Authentication
When an actor claims to have a given identity, the product does not prove or insufficiently proves that the claim is correct.
How to prevent it
- Architecture and Design: Use an authentication framework or library such as the OWASP ESAPI Authentication feature.
References
Advisories
Packages
Other links
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-xg5p-8wg5-rhxm Phone information disclosure vulnerability | High | Also affects plone |
| GHSA-5xfx-55x4-j223 Cross-Frame Scripting vulnerability has been found on Plone CMS | High | Also affects plone |
| GHSA-47p5-p3jw-w78w Server-Side Request Forgery in Plone CMS | High | Also affects plone |
| GHSA-cvwc-g7fw-7xrj Plone XSS Vulnerability | Medium | Also affects plone |
| GHSA-pwgm-jvqv-6v8p Plone anonymous access to sub-objects in CMFEditions where KwAsAttributes classes were publishable | High | Also affects plone |
| GHSA-46f9-f8jm-mw2x Plone Cross-site Scripting vulnerability in the LiveSearch module | Medium | Also affects plone |
| GHSA-hjp5-hv33-q58g Plone credentials stored in session cookie | Medium | Also affects plone |
| GHSA-593c-j348-f3gv Plone Improper Session Management | High | Also affects plone |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor