Skip to content

GHSA-65p7-pjj8-ggmr

Member account takeover

Medium npm
Severity
6.5 / 10
Medium · CVSS 3.1
Exploit chance (EPSS)
—
No score published
Known exploited
No
Not in CISA's catalog
Weakness
—
Not classified
Fix
3.42.6
Upgrade ghost to this version or later

Description

Impact

An error in the implementation of the member email change functionality allows unauthenticated users to change the email address of arbitrary member accounts to one they control by crafting a request to the relevant API endpoint, and validating the new address via magic link sent to the new email address.

Ghost(Pro) has already been patched. Self-hosters are impacted if running Ghost a version between 3.18.0 and 4.15.0 with members functionality enabled.

Patches

Fixed in 4.15.1, all 4.x sites should upgrade as soon as possible. Fixed in 3.42.6, all 3.x sites should upgrade as soon as possible.

Workarounds

The patch in 4.15.1 and 3.42.6 adds a new authenticated endpoint for updating member email addresses. Updating Ghost is the quickest complete solution.

As a workaround, if for any reason you cannot update your Ghost instance, you can block the POST /members/api/send-magic-link/ endpoint, which will also disable member login and signup for your site.

For more information

If you have any questions or comments about this advisory:

Affected versions

npm

PackageVulnerableFixed in
ghost
>= 3.18.0, < 3.42.6
3.42.6
ghost
>= 4.0.0, < 4.15.1
4.15.1

How to fix

Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.

ghost npm → 3.42.6

npm
npm install ghost@3.42.6
yarn
yarn add ghost@3.42.6
pnpm
pnpm add ghost@3.42.6

Severity breakdown

CVSS 3.1 6.5

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N

Attack vector
Network
Attack complexity
Low
Privileges required
None
User interaction
None
Scope
Unchanged
Confidentiality
Low
Integrity
Low
Availability
None

References

Timeline

  1. Last updated by the source
  2. Published
AdvisorySeverityWhy it's related
GHSA-x3mg-q38v-m562
Ghost: Authorization Issue Allowed Author Role to Delete any Post
Medium Also affects ghost
GHSA-8575-cr6v-7jh4
Ghost: Stored XSS via SVG Uploads Bypassing Sanitization
High Also affects ghost
GHSA-r7f2-6fj8-6fg2
Ghost: Private IP Filtering Bypass via IPv6 Transition Addresses
Medium Also affects ghost
GHSA-322m-ff4g-9vx9
Ghost: Server-Side Request Forgery in Bookmark Fetching
Medium Also affects ghost
GHSA-fwh9-qg68-vxp4
Ghost: Regular Expression Denial of Service in Content Import
Medium Also affects ghost
GHSA-9m4w-fmjw-fvjq
Ghost: Regular Expression Denial of Service in External Media Inliner
Medium Also affects ghost
GHSA-hqq2-xqr2-fmx2
Ghost : Stored XSS via SVG Files in Content Imports
Medium Also affects ghost
GHSA-69qc-f5m6-889c
Ghost: Stored XSS via Embed Card Previews
High Also affects ghost
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor