GHSA-647v-r7qq-24fh BIT-tensorflow-2023-25673 CVE-2023-25673 PYSEC-2026-3115 PYSEC-2026-3281 PYSEC-2026-956
TensorFlow has Floating Point Exception in TensorListSplit with XLA
- Severity
- 7.5 / 10
- High · CVSS 3.1
- Exploit chance (EPSS)
- 0.39%
- Chance of exploitation in the next 30 days. Higher than 33.62% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- CWE-697 Incorrect Comparison
- Fix
- Available
- 3 packages have a fixed version
Description
Impact
FPE in TensorListSplit with XLA
import tensorflow as tf
func = tf.raw_ops.TensorListSplit
para = {'tensor': [1], 'element_shape': -1, 'lengths': [0]}
@tf.function(jit_compile=True)
def fuzz_jit():
y = func(**para)
return y
print(fuzz_jit())
Patches
We have patched the issue in GitHub commit 728113a3be690facad6ce436660a0bc1858017fa.
The fix will be included in TensorFlow 2.12.0. We will also cherrypick this commit on TensorFlow 2.11.1
For more information
Please consult our security guide for more information regarding the security model and how to contact us with issues and questions.
Attribution
This vulnerability has been reported by r3pwnx
Affected versions
PyPI
| Package | Vulnerable | Fixed in |
|---|---|---|
| tensorflow | < 2.11.1 |
2.11.1 |
| tensorflow-cpu | < 2.11.1 |
2.11.1 |
| tensorflow-gpu | < 2.11.1 |
2.11.1 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
tensorflow PyPI → 2.11.1
- pip
pip install --upgrade "tensorflow>=2.11.1"- poetry
poetry add "tensorflow>=2.11.1"- uv
uv add "tensorflow>=2.11.1"
tensorflow-cpu PyPI → 2.11.1
- pip
pip install --upgrade "tensorflow-cpu>=2.11.1"- poetry
poetry add "tensorflow-cpu>=2.11.1"- uv
uv add "tensorflow-cpu>=2.11.1"
tensorflow-gpu PyPI → 2.11.1
- pip
pip install --upgrade "tensorflow-gpu>=2.11.1"- poetry
poetry add "tensorflow-gpu>=2.11.1"- uv
uv add "tensorflow-gpu>=2.11.1"
Severity breakdown
CVSS 3.1 7.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Attack vector
- Network
- Attack complexity
- Low
- Privileges required
- None
- User interaction
- None
- Scope
- Unchanged
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Weakness
CWE-697: Incorrect Comparison
The product compares two entities in a security-relevant context, but the comparison is incorrect.
References
Advisories
Packages
Other links
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-gjh7-xx4r-x345 TensorFlow has segfault in array_ops.upper_bound | High | Also affects tensorflow |
| GHSA-fxgc-95xx-grvq TensorFlow Denial of Service vulnerability | Medium | Also affects tensorflow |
| GHSA-93vr-9q9m-pj8p TensorFlow vulnerable to Out-of-Bounds Read in DynamicStitch | High | Also affects tensorflow |
| GHSA-qjqc-vqcf-5qvj TensorFlow vulnerable to seg fault in `tf.raw_ops.Print` | High | Also affects tensorflow |
| GHSA-7jvm-xxmr-v5cw TensorFlow vulnerable to integer overflow in EditDistance | High | Also affects tensorflow |
| GHSA-64jg-wjww-7c5w TensorFlow has Null Pointer Error in TensorArrayConcatV2 | High | Also affects tensorflow |
| GHSA-6hg6-5c2q-7rcr TensorFlow has Heap-buffer-overflow in AvgPoolGrad | High | Also affects tensorflow |
| GHSA-558h-mq8x-7q9g TensorFlow has Null Pointer Error in SparseSparseMaximum | High | Also affects tensorflow |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor