Skip to content

GHSA-5x28-3f32-x523

Drupal core Access control bypass

Medium Packagist
Severity
4.3 / 10
Medium · CVSS 3.1
Exploit chance (EPSS)
—
No score published
Known exploited
No
Not in CISA's catalog
Weakness
—
Not classified
Fix
8.7.11
Upgrade drupal/drupal to this version or later

Description

The Media Library module has a security vulnerability whereby it doesn't sufficiently restrict access to media items in certain configurations.

Solution:

If you are using Drupal 8.7.x, you should upgrade to Drupal 8.7.11. If you are using Drupal 8.8.x, you should upgrade to Drupal 8.8.1. Versions of Drupal 8 prior to 8.7.x are end-of-life and do not receive security coverage.

Alternatively, you may mitigate this vulnerability by unchecking the "Enable advanced UI" checkbox on /admin/config/media/media-library. (This mitigation is not available in 8.7.x.)

Affected versions

Packagist

PackageVulnerableFixed in
drupal/drupal
>= 8.0.0, < 8.7.11
8.7.11
drupal/drupal
>= 8.8.0, < 8.8.1
8.8.1

How to fix

Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.

drupal/drupal Packagist → 8.7.11

composer
composer require drupal/drupal:^8.7.11

Severity breakdown

CVSS 3.1 4.3

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N

Attack vector
Network
Attack complexity
Low
Privileges required
Low
User interaction
None
Scope
Unchanged
Confidentiality
Low
Integrity
None
Availability
None

References

Timeline

  1. Published
  2. Last updated by the source
AdvisorySeverityWhy it's related
CVE-2020-13671
Drupal core Unrestricted Upload of File with Dangerous Type
High Known exploited Also affects drupal/drupal
CVE-2019-6340
Drupal Core Remote Code Execution Vulnerability
High Known exploited Also affects drupal/drupal
CVE-2018-7602
Drupal Core Remote Code Execution Vulnerability
Critical Known exploited Also affects drupal/drupal
CVE-2018-7600
Drupal Core Remote Code Execution Vulnerability
Critical Known exploited Also affects drupal/drupal
DRUPAL-CORE-2024-008
Drupal core contains a potential PHP Object Injection vulnerability
Critical Also affects drupal/drupal
DRUPAL-CORE-2024-007
Drupal core contains a potential PHP Object Injection vulnerability
Critical Also affects drupal/drupal
DRUPAL-CORE-2024-006
Drupal core contains a potential PHP Object Injection vulnerability
Critical Also affects drupal/drupal
DRUPAL-CORE-2024-004
Drupal core Access bypass
High Also affects drupal/drupal
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor