Skip to content

GHSA-5rrg-rr89-x9mv CVE-2021-20228 PYSEC-2021-1

Ansible Exposes Sensitive Information

High PyPI
Severity
0.0 / 10
High · CVSS 4.0
Exploit chance (EPSS)
2.06%
Chance of exploitation in the next 30 days. Higher than 81.33% of scored vulnerabilities.
Known exploited
No
Not in CISA's catalog
Weakness
CWE-200 Exposure of Sensitive Information to an Unauthorized Actor
CWE-522 Insufficiently Protected Credentials
Fix
2.10.6rc1
Upgrade ansible to this version or later

Description

A flaw was found in the Ansible Engine prior to 2.10.6rc1, 2.9.18rc1, and 2.8.19rc1, where sensitive info is not masked by default and is not protected by the no_log feature when using the sub-option feature of the basic.py module. This flaw allows an attacker to obtain sensitive information. The highest threat from this vulnerability is to confidentiality.

Affected versions

PyPI

PackageVulnerableFixed in
ansible
>= 2.10.0a1, < 2.10.6rc1
2.10.6rc1
ansible
>= 2.9.0a1, < 2.9.18rc1
2.9.18rc1
ansible
< 2.8.19rc1
2.8.19rc1
ansible
< 2.9.19
2.9.19

How to fix

Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.

ansible PyPI → 2.10.6rc1

pip
pip install --upgrade "ansible>=2.10.6rc1"
poetry
poetry add "ansible>=2.10.6rc1"
uv
uv add "ansible>=2.10.6rc1"

Severity breakdown

CVSS 4.0 0.0

CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N

Attack vector
Network
Attack complexity
Low
Attack requirements
None
Privileges required
None
User interaction
None
Confidentiality (vulnerable system)
High
Integrity (vulnerable system)
None
Availability (vulnerable system)
None
Confidentiality (subsequent systems)
None
Integrity (subsequent systems)
None
Availability (subsequent systems)
None

CVSS 3.1 7.5

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Attack vector
Network
Attack complexity
Low
Privileges required
None
User interaction
None
Scope
Unchanged
Confidentiality
High
Integrity
None
Availability
None

Weakness

CWE-200: Exposure of Sensitive Information to an Unauthorized Actor

The product exposes sensitive information to an actor that is not explicitly authorized to have access to that information.

How to prevent it
  • Architecture and Design: Compartmentalize the system to have "safe" areas where trust boundaries can be unambiguously drawn. Do not allow sensitive data to go outside of the trust boundary and always be careful when interfacing with a compartment outside of the safe area. Ensure that appropriate compartmentalization is built into the system design, and the compartmentalization allows for and reinforces privilege separation functionality. Architects and designers should rely on the principle of least privilege to decide the appropriate time to use privileges and the time to drop privileges.

CWE-522: Insufficiently Protected Credentials

The product transmits or stores authentication credentials, but it uses an insecure method that is susceptible to unauthorized interception and/or retrieval.

How to prevent it
  • Architecture and Design: Use an appropriate security mechanism to protect the credentials.
  • Architecture and Design: Make appropriate use of cryptography to protect the credentials.
  • Implementation: Use industry standards to protect the credentials (e.g. LDAP, keystore, etc.).

References

Timeline

  1. Published
  2. Last updated by the source
  3. Latest EPSS score
AdvisorySeverityWhy it's related
GHSA-8ggh-xwr9-3373
Ansible Community General Collection is vulnerable to exposure of sensitive information
Medium Also affects ansible
GHSA-jpvw-p8pr-9g2x
Ansible symlink attack vulnerability
Medium Also affects ansible
GHSA-cpx3-93w7-457x
Ansible leaks password to logs
High Also affects ansible
GHSA-fh5v-5f35-2rv2
Insertion of Sensitive Information into Log File in ansible
Medium Also affects ansible
GHSA-4r65-35qq-ch8j
Ansible discloses sensitive information in traceback error message
Medium Also affects ansible
GHSA-2pfh-q76x-gwvm
Improper Input Validation and Command Injection in Ansible
High Also affects ansible
PYSEC-2021-126
A flaw was found in Ansible if an ansible user sets ANSIBLE_ASYNC_DIR to a subdirectory of a world writable directory.
Not rated yet Also affects ansible
GHSA-r6h7-5pq2-j77h
Insufficiently random values in Ansible
Medium Also affects ansible
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor