GHSA-5fvx-2jj3-6mff BIT-elasticsearch-2021-22132 CVE-2021-22132
Insufficiently Protected Credentials in Elasticsearch
- Severity
- 4.8 / 10
- Medium · CVSS 3.1
- Exploit chance (EPSS)
- 1.22%
- Chance of exploitation in the next 30 days. Higher than 68.73% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- CWE-522 Insufficiently Protected Credentials
- Fix
7.10.2- Upgrade org.elasticsearch:elasticsearch to this version or later
Description
Elasticsearch versions 7.7.0 to 7.10.1 contain an information disclosure flaw in the async search API. Users who execute an async search will improperly store the HTTP headers. An Elasticsearch user with the ability to read the .tasks index could obtain sensitive request headers of other users in the cluster. This issue is fixed in Elasticsearch 7.10.2
Affected versions
Maven
| Package | Vulnerable | Fixed in |
|---|---|---|
| org.elasticsearch:elasticsearch | >= 7.7.0, < 7.10.2 |
7.10.2 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
org.elasticsearch:elasticsearch Maven → 7.10.2
- maven
<dependency><groupId>org.elasticsearch</groupId><artifactId>elasticsearch</artifactId><version>7.10.2</version></dependency>- gradle
implementation("org.elasticsearch:elasticsearch:7.10.2")
Severity breakdown
CVSS 3.1 4.8
CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:N/A:N
- Attack vector
- Network
- Attack complexity
- High
- Privileges required
- Low
- User interaction
- Required
- Scope
- Unchanged
- Confidentiality
- High
- Integrity
- None
- Availability
- None
Weakness
CWE-522: Insufficiently Protected Credentials
The product transmits or stores authentication credentials, but it uses an insecure method that is susceptible to unauthorized interception and/or retrieval.
How to prevent it
- Architecture and Design: Use an appropriate security mechanism to protect the credentials.
- Architecture and Design: Make appropriate use of cryptography to protect the credentials.
- Implementation: Use industry standards to protect the credentials (e.g. LDAP, keystore, etc.).
References
Advisories
Other links
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-mrfm-jxgf-2h6v Elasticsearch Improper Access Control vulnerability | High Known exploited | Also affects org.elasticsearch:elasticsearch |
| GHSA-w94p-6mhw-4qxw Improper Access Control in Elasticsearch | High Known exploited | Also affects org.elasticsearch:elasticsearch |
| GHSA-mm3m-5497-xggg Elasticsearch Uncontrolled Resource Consumption Vulnerability | High | Also affects org.elasticsearch:elasticsearch |
| GHSA-5xm9-x7x4-4j5x Elasticsearch Vulnerable to Stack Overflow due to a Large Recursion | High | Also affects org.elasticsearch:elasticsearch |
| GHSA-jgx4-7v3v-vwfm Elasticsearch allocation of resources without limits or throttling leads to crash | High | Also affects org.elasticsearch:elasticsearch |
| GHSA-5mpw-4546-2wcr Elasticsearch Incorrect Authorization vulnerability | Medium | Also affects org.elasticsearch:elasticsearch |
| GHSA-5v8f-xx9m-wj44 Elasticsearch stores private key on disk unencrypted | High | Also affects org.elasticsearch:elasticsearch |
| GHSA-2hjr-vmf3-xwvp Elasticsearch Insertion of Sensitive Information into Log File | Medium | Also affects org.elasticsearch:elasticsearch |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor