Skip to content

GHSA-4mp7-2m29-gqxf BIT-vault-2020-16251 CVE-2020-16251 GO-2024-2488

HashiCorp Vault Authentication bypass

High Go
Severity
8.2 / 10
High · CVSS 3.1
Exploit chance (EPSS)
2.83%
Chance of exploitation in the next 30 days. Higher than 86.61% of scored vulnerabilities.
Known exploited
No
Not in CISA's catalog
Weakness
CWE-287 Improper Authentication
Fix
1.2.5
Upgrade github.com/hashicorp/vault to this version or later

Description

HashiCorp Vault and Vault Enterprise versions 0.8.3 and newer, when configured with the GCP GCE auth method, may be vulnerable to authentication bypass. Fixed in 1.2.5, 1.3.8, 1.4.4, and 1.5.1.

Affected versions

Go

PackageVulnerableFixed in
github.com/hashicorp/vault
>= 0.8.3, < 1.2.5
1.2.5
github.com/hashicorp/vault
>= 1.3.0, < 1.3.8
1.3.8
github.com/hashicorp/vault
>= 1.4.0, < 1.4.4
1.4.4
github.com/hashicorp/vault
>= 1.5.0, < 1.5.1
1.5.1
github.com/hashicorp/vault
>= 0.8.3, < 1.2.5
>= 1.3.0, < 1.3.8
>= 1.4.0, < 1.4.4
>= 1.5.0, < 1.5.1
1.2.5
1.3.8
1.4.4
1.5.1

How to fix

Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.

github.com/hashicorp/vault Go → 1.2.5

go
go get github.com/hashicorp/vault@v1.2.5 && go mod tidy

Severity breakdown

CVSS 3.1 8.2

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:N

Attack vector
Network
Attack complexity
Low
Privileges required
None
User interaction
None
Scope
Unchanged
Confidentiality
Low
Integrity
High
Availability
None

Weakness

CWE-287: Improper Authentication

When an actor claims to have a given identity, the product does not prove or insufficiently proves that the claim is correct.

How to prevent it
  • Architecture and Design: Use an authentication framework or library such as the OWASP ESAPI Authentication feature.

References

Timeline

  1. Published
  2. Last updated by the source
  3. Latest EPSS score
AdvisorySeverityWhy it's related
GHSA-88v5-9hxc-f85r
HashiCorp Vault Vulnerable to Denial-of-Service via Unauthenticated Root Token Generation/Rekey Operations
High Also affects github.com/hashicorp/vault
GHSA-8r5m-3f66-qpr3
HashiCorp Vault has Server-Side Request Forgery in ACME Challenge Validation via Attacker-Controlled DNS
High Also affects github.com/hashicorp/vault
GHSA-72gw-fmmr-c4r4
HashiCorp Vault May Expose Tokens to Auth Plugins Due to Incorrect Header Sanitization
High Also affects github.com/hashicorp/vault
GHSA-m2w4-8ggf-rj47
HashiCorp Vault has a KVv2 Metadata and Secret Deletion Policy Bypass that leads to Denial-of-Service
High Also affects github.com/hashicorp/vault
GHSA-vp5w-xcfc-73wf
Hashicorp Vault and Vault Enterprise vulnerable to a denial of service when processing JSON
High Also affects github.com/hashicorp/vault
GHSA-9g4h-h484-3578
HashiCorp Vault and Vault Enterprise's AWS Auth method may be susceptible to authentication bypass
High Also affects github.com/hashicorp/vault
GHSA-8f82-53h8-2p34
HashiCorp Vault Community Edition Denial of Service Though Complex JSON Payloads
High Also affects github.com/hashicorp/vault
GHSA-7rx2-769v-hrwf
HashiCorp Vault ldap auth method may not have correctly enforced MFA
High Also affects github.com/hashicorp/vault
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor