Skip to content

GHSA-4c4g-crqm-xrxw BIT-tensorflow-2021-37682 CVE-2021-37682 PYSEC-2021-304 PYSEC-2021-595 PYSEC-2021-793

Use of unitialized value in TFLite

Medium PyPI
Severity
0.0 / 10
Medium · CVSS 4.0
Exploit chance (EPSS)
0.18%
Chance of exploitation in the next 30 days. Higher than 7.53% of scored vulnerabilities.
Known exploited
No
Not in CISA's catalog
Weakness
CWE-908 Use of Uninitialized Resource
Fix
Available
3 packages have a fixed version

Description

Impact

All TFLite operations that use quantization can be made to use unitialized values. For example:

    const auto* affine_quantization =
        reinterpret_cast<TfLiteAffineQuantization*>(
            filter->quantization.params);

The issue stems from the fact that quantization.params is only valid if quantization.type is different that kTfLiteNoQuantization. However, these checks are missing in large parts of the code.

Patches

We have patched the issue in GitHub commits 537bc7c723439b9194a358f64d871dd326c18887, 4a91f2069f7145aab6ba2d8cfe41be8a110c18a5 and 8933b8a21280696ab119b63263babdb54c298538.

The fix will be included in TensorFlow 2.6.0. We will also cherrypick this commit on TensorFlow 2.5.1, TensorFlow 2.4.3, and TensorFlow 2.3.4, as these are also affected and still in supported range.

For more information

Please consult our security guide for more information regarding the security model and how to contact us with issues and questions.

Attribution

This vulnerability has been reported by members of the Aivul Team from Qihoo 360.

Affected versions

PyPI

PackageVulnerableFixed in
tensorflow
< 2.3.4
2.3.4
tensorflow
>= 2.4.0, < 2.4.3
2.4.3
tensorflow
>= 2.5.0, < 2.5.1
2.5.1
tensorflow
>= 2.3.0, < 2.3.4
>= 2.4.0, < 2.4.3
2.3.4
2.4.3
tensorflow-cpu
< 2.3.4
2.3.4
tensorflow-cpu
>= 2.4.0, < 2.4.3
2.4.3
tensorflow-cpu
>= 2.5.0, < 2.5.1
2.5.1
tensorflow-cpu
>= 2.3.0, < 2.3.4
>= 2.4.0, < 2.4.3
2.3.4
2.4.3
tensorflow-gpu
< 2.3.4
2.3.4
tensorflow-gpu
>= 2.4.0, < 2.4.3
2.4.3
tensorflow-gpu
>= 2.5.0, < 2.5.1
2.5.1
tensorflow-gpu
>= 2.3.0, < 2.3.4
>= 2.4.0, < 2.4.3
2.3.4
2.4.3

How to fix

Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.

tensorflow PyPI → 2.3.4

pip
pip install --upgrade "tensorflow>=2.3.4"
poetry
poetry add "tensorflow>=2.3.4"
uv
uv add "tensorflow>=2.3.4"

tensorflow-cpu PyPI → 2.3.4

pip
pip install --upgrade "tensorflow-cpu>=2.3.4"
poetry
poetry add "tensorflow-cpu>=2.3.4"
uv
uv add "tensorflow-cpu>=2.3.4"

tensorflow-gpu PyPI → 2.3.4

pip
pip install --upgrade "tensorflow-gpu>=2.3.4"
poetry
poetry add "tensorflow-gpu>=2.3.4"
uv
uv add "tensorflow-gpu>=2.3.4"

Severity breakdown

CVSS 4.0 0.0

CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:L/SC:N/SI:N/SA:N

Attack vector
Local
Attack complexity
Low
Attack requirements
None
Privileges required
Low
User interaction
None
Confidentiality (vulnerable system)
None
Integrity (vulnerable system)
Low
Availability (vulnerable system)
Low
Confidentiality (subsequent systems)
None
Integrity (subsequent systems)
None
Availability (subsequent systems)
None

CVSS 3.1 4.4

CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:L

Attack vector
Local
Attack complexity
Low
Privileges required
Low
User interaction
None
Scope
Unchanged
Confidentiality
None
Integrity
Low
Availability
Low

Weakness

CWE-908: Use of Uninitialized Resource

The product uses or accesses a resource that has not been initialized.

How to prevent it
  • Implementation: Explicitly initialize the resource before use. If this is performed through an API function or standard procedure, follow all required steps.
  • Implementation: Pay close attention to complex conditionals that affect initialization, since some branches might not perform the initialization.
  • Implementation: Avoid race conditions (CWE-362) during initialization routines.
  • Build and Compilation: Run or compile the product with settings that generate warnings about uninitialized variables or data.

References

Timeline

  1. Published
  2. Last updated by the source
  3. Latest EPSS score
AdvisorySeverityWhy it's related
GHSA-gjh7-xx4r-x345
TensorFlow has segfault in array_ops.upper_bound
High Also affects tensorflow
GHSA-fxgc-95xx-grvq
TensorFlow Denial of Service vulnerability
Medium Also affects tensorflow
GHSA-93vr-9q9m-pj8p
TensorFlow vulnerable to Out-of-Bounds Read in DynamicStitch
High Also affects tensorflow
GHSA-qjqc-vqcf-5qvj
TensorFlow vulnerable to seg fault in `tf.raw_ops.Print`
High Also affects tensorflow
GHSA-7jvm-xxmr-v5cw
TensorFlow vulnerable to integer overflow in EditDistance
High Also affects tensorflow
GHSA-64jg-wjww-7c5w
TensorFlow has Null Pointer Error in TensorArrayConcatV2
High Also affects tensorflow
GHSA-6hg6-5c2q-7rcr
TensorFlow has Heap-buffer-overflow in AvgPoolGrad
High Also affects tensorflow
GHSA-558h-mq8x-7q9g
TensorFlow has Null Pointer Error in SparseSparseMaximum
High Also affects tensorflow
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor