Skip to content

GHSA-3w67-q784-6w7c BIT-tensorflow-2021-29589 CVE-2021-29589 PYSEC-2021-226 PYSEC-2021-517 PYSEC-2021-715

Division by zero in TFLite's implementation of `GatherNd`

Low PyPI
Severity
0.0 / 10
Low · CVSS 4.0
Exploit chance (EPSS)
0.20%
Chance of exploitation in the next 30 days. Higher than 10.02% of scored vulnerabilities.
Known exploited
No
Not in CISA's catalog
Weakness
CWE-369 Divide By Zero
Fix
Available
3 packages have a fixed version

Description

Impact

The reference implementation of the GatherNd TFLite operator is vulnerable to a division by zero error:

ret.dims_to_count[i] = remain_flat_size / params_shape.Dims(i);

An attacker can craft a model such that params input would be an empty tensor. In turn, params_shape.Dims(.) would be zero, in at least one dimension.

Patches

We have patched the issue in GitHub commit 8e45822aa0b9f5df4b4c64f221e64dc930a70a9d.

The fix will be included in TensorFlow 2.5.0. We will also cherrypick this commit on TensorFlow 2.4.2, TensorFlow 2.3.3, TensorFlow 2.2.3 and TensorFlow 2.1.4, as these are also affected and still in supported range.

For more information

Please consult our security guide for more information regarding the security model and how to contact us with issues and questions.

Attribution

This vulnerability has been reported by members of the Aivul Team from Qihoo 360.

Affected versions

PyPI

PackageVulnerableFixed in
tensorflow
< 2.1.4
2.1.4
tensorflow
>= 2.2.0, < 2.2.3
2.2.3
tensorflow
>= 2.3.0, < 2.3.3
2.3.3
tensorflow
>= 2.4.0, < 2.4.2
2.4.2
tensorflow
< 2.2.0rc0
>= 2.2.0, < 2.3.0rc0
>= 2.3.0, < 2.3.4
>= 2.4.0, < 2.4.3
2.2.0rc0
2.3.0rc0
2.3.4
2.4.3
tensorflow-cpu
< 2.1.4
2.1.4
tensorflow-cpu
>= 2.2.0, < 2.2.3
2.2.3
tensorflow-cpu
>= 2.3.0, < 2.3.3
2.3.3
tensorflow-cpu
>= 2.4.0, < 2.4.2
2.4.2
tensorflow-cpu
< 2.2.0rc0
>= 2.2.0, < 2.3.0rc0
>= 2.3.0, < 2.3.4
>= 2.4.0, < 2.4.3
2.2.0rc0
2.3.0rc0
2.3.4
2.4.3
tensorflow-gpu
< 2.1.4
2.1.4
tensorflow-gpu
>= 2.2.0, < 2.2.3
2.2.3
tensorflow-gpu
>= 2.4.0, < 2.4.2
2.4.2
tensorflow-gpu
>= 2.3.0, < 2.3.3
2.3.3
tensorflow-gpu
< 2.2.0rc0
>= 2.2.0, < 2.3.0rc0
>= 2.3.0, < 2.3.4
>= 2.4.0, < 2.4.3
2.2.0rc0
2.3.0rc0
2.3.4
2.4.3

How to fix

Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.

tensorflow PyPI → 2.1.4

pip
pip install --upgrade "tensorflow>=2.1.4"
poetry
poetry add "tensorflow>=2.1.4"
uv
uv add "tensorflow>=2.1.4"

tensorflow-cpu PyPI → 2.1.4

pip
pip install --upgrade "tensorflow-cpu>=2.1.4"
poetry
poetry add "tensorflow-cpu>=2.1.4"
uv
uv add "tensorflow-cpu>=2.1.4"

tensorflow-gpu PyPI → 2.1.4

pip
pip install --upgrade "tensorflow-gpu>=2.1.4"
poetry
poetry add "tensorflow-gpu>=2.1.4"
uv
uv add "tensorflow-gpu>=2.1.4"

Severity breakdown

CVSS 4.0 0.0

CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N

Attack vector
Network
Attack complexity
Low
Attack requirements
Present
Privileges required
Low
User interaction
None
Confidentiality (vulnerable system)
None
Integrity (vulnerable system)
None
Availability (vulnerable system)
Low
Confidentiality (subsequent systems)
None
Integrity (subsequent systems)
None
Availability (subsequent systems)
None

CVSS 3.1 2.5

CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:N/I:N/A:L

Attack vector
Local
Attack complexity
High
Privileges required
Low
User interaction
None
Scope
Unchanged
Confidentiality
None
Integrity
None
Availability
Low

Weakness

CWE-369: Divide By Zero

The product divides a value by zero.

References

Timeline

  1. Published
  2. Last updated by the source
  3. Latest EPSS score
AdvisorySeverityWhy it's related
GHSA-gjh7-xx4r-x345
TensorFlow has segfault in array_ops.upper_bound
High Also affects tensorflow
GHSA-fxgc-95xx-grvq
TensorFlow Denial of Service vulnerability
Medium Also affects tensorflow
GHSA-93vr-9q9m-pj8p
TensorFlow vulnerable to Out-of-Bounds Read in DynamicStitch
High Also affects tensorflow
GHSA-qjqc-vqcf-5qvj
TensorFlow vulnerable to seg fault in `tf.raw_ops.Print`
High Also affects tensorflow
GHSA-7jvm-xxmr-v5cw
TensorFlow vulnerable to integer overflow in EditDistance
High Also affects tensorflow
GHSA-64jg-wjww-7c5w
TensorFlow has Null Pointer Error in TensorArrayConcatV2
High Also affects tensorflow
GHSA-6hg6-5c2q-7rcr
TensorFlow has Heap-buffer-overflow in AvgPoolGrad
High Also affects tensorflow
GHSA-558h-mq8x-7q9g
TensorFlow has Null Pointer Error in SparseSparseMaximum
High Also affects tensorflow
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor