GHSA-3qrq-r688-vvh4 CVE-2022-24892
Multiple valid tokens for password reset in Shopware
- Severity
- 6.4 / 10
- Medium · CVSS 3.1
- Exploit chance (EPSS)
- 0.87%
- Chance of exploitation in the next 30 days. Higher than 58.81% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- CWE-640 Weak Password Recovery Mechanism for Forgotten Password
- Fix
5.7.9- Upgrade shopware/shopware to this version or later
Description
Impact
Multiple tokens for password reset could be requested. All tokens could be used to change the password. This makes it possible for an attacker to take over the victims account if s/he gains access to the victims email account and finds unused password reset token in the emails within the time frame of two hours.
Patches
We recommend updating to the current version 5.7.9. You can get the update to 5.7.9 regularly via the Auto-Updater or directly via the download overview. https://www.shopware.com/en/changelog-sw5/#5-7-9
For older versions you can use the Security Plugin: https://store.shopware.com/en/swag575294366635f/shopware-security-plugin.html
References
https://docs.shopware.com/en/shopware-5-en/security-updates/security-update-04-2022
Affected versions
Packagist
| Package | Vulnerable | Fixed in |
|---|---|---|
| shopware/shopware | >= 5.0.4, < 5.7.9 |
5.7.9 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
shopware/shopware Packagist → 5.7.9
- composer
composer require shopware/shopware:^5.7.9
Severity breakdown
CVSS 3.1 6.4
CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:N
- Attack vector
- Network
- Attack complexity
- High
- Privileges required
- Low
- User interaction
- Required
- Scope
- Unchanged
- Confidentiality
- High
- Integrity
- High
- Availability
- None
Weakness
CWE-640: Weak Password Recovery Mechanism for Forgotten Password
The product contains a mechanism for users to recover or change their passwords without knowing the original password, but the mechanism is weak.
How to prevent it
- Architecture and Design: Make sure that all input supplied by the user to the password recovery mechanism is thoroughly filtered and validated.
- Architecture and Design: Do not use standard weak security questions and use several security questions.
- Architecture and Design: Make sure that there is throttling on the number of incorrect answers to a security question. Disable the password recovery functionality after a certain (small) number of incorrect guesses.
- Architecture and Design: Require that the user properly answers the security question prior to resetting their password and sending the new password to the e-mail address of record.
- Architecture and Design: Never allow the user to control what e-mail address the new password will be sent to in the password recovery mechanism.
- Architecture and Design: Assign a new temporary password rather than revealing the original password.
References
Advisories
Packages
Other links
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-7cw6-7h3h-v8pf Shopware Has Improper Control of Generation of Code in Twig rendered views | High | Also affects shopware/shopware |
| GHSA-6w82-v552-wjw2 Shopware Storefront Reflected XSS in Storefront Login Page | Medium | Also affects shopware/shopware |
| GHSA-9v82-vcjx-m76j Shopware: Reflective Cross Site-Scripting (XSS) in CMS components | High | Also affects shopware/shopware |
| GHSA-83jv-4prm-34g7 Shopware Remote Code Execution Vulnerability | Critical | Also affects shopware/shopware |
| GHSA-7336-ghhp-f2qj Shopware Remote Code Execution Vulnerability | Critical | Also affects shopware/shopware |
| GHSA-jqr7-5h7r-ch8p Shopware Non-Persistent XSS in the Frontend | Medium | Also affects shopware/shopware |
| GHSA-q3g4-2vw9-xv27 Shopware Remote Code Execution Vulnerability | Critical | Also affects shopware/shopware |
| GHSA-gh66-fp7j-98v5 Shopware improper mail validation vulnerability | Medium | Also affects shopware/shopware |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor