Skip to content

GHSA-3h52-269p-cp9r CVE-2025-48068

Information exposure in Next.js dev server due to lack of origin verification

Medium npm
Severity
0.0 / 10
Medium · CVSS 4.0
Exploit chance (EPSS)
0.20%
Chance of exploitation in the next 30 days. Higher than 10.25% of scored vulnerabilities.
Known exploited
No
Not in CISA's catalog
Weakness
CWE-1385 Missing Origin Validation in WebSockets
Fix
15.2.2
Upgrade next to this version or later

Description

Summary

A low-severity vulnerability in Next.js has been fixed in version 15.2.2. This issue may have allowed limited source code exposure when the dev server was running with the App Router enabled. The vulnerability only affects local development environments and requires the user to visit a malicious webpage while npm run dev is active.

Because the mitigation is potentially a breaking change for some development setups, to opt-in to the fix, you must configure allowedDevOrigins in your next config after upgrading to a patched version. Learn more.

Learn more: https://vercel.com/changelog/cve-2025-48068

Credit

Thanks to sapphi-red and Radman Siddiki for responsibly disclosing this issue.

Affected versions

npm

PackageVulnerableFixed in
next
>= 15.0.0, < 15.2.2
15.2.2
next
>= 13.0, < 14.2.30
14.2.30

How to fix

Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.

next npm → 15.2.2

npm
npm install next@15.2.2
yarn
yarn add next@15.2.2
pnpm
pnpm add next@15.2.2

Severity breakdown

CVSS 4.0 0.0

CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:L/VI:N/VA:N/SC:L/SI:N/SA:N

Attack vector
Network
Attack complexity
Low
Attack requirements
Present
Privileges required
None
User interaction
Passive
Confidentiality (vulnerable system)
Low
Integrity (vulnerable system)
None
Availability (vulnerable system)
None
Confidentiality (subsequent systems)
Low
Integrity (subsequent systems)
None
Availability (subsequent systems)
None

CVSS 3.1 4.3

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:N

Attack vector
Network
Attack complexity
Low
Privileges required
None
User interaction
Required
Scope
Unchanged
Confidentiality
Low
Integrity
None
Availability
None

Weakness

CWE-1385: Missing Origin Validation in WebSockets

The product uses a WebSocket, but it does not properly verify that the source of data or communication is valid.

How to prevent it
  • Implementation: Enable CORS-like access restrictions by verifying the 'Origin' header during the WebSocket handshake.
  • Implementation: Use a randomized CSRF token to verify requests.
  • Implementation: Use TLS to securely communicate using 'wss' (WebSocket Secure) instead of 'ws'.
  • Architecture and Design, Implementation: Require user authentication prior to the WebSocket connection being established. For example, the WS library in Node has a 'verifyClient' function.
  • Implementation: Leverage rate limiting to prevent against DoS. Use of the leaky bucket algorithm can help with this.
  • Implementation: Use a library that provides restriction of the payload size. For example, WS library for Node includes 'maxPayloadoption' that can be set.
  • Implementation: Treat data/input as untrusted in both directions and apply the same data/input sanitization as XSS, SQLi, etc.

References

Timeline

  1. Published
  2. Last updated by the source
  3. Latest EPSS score
AdvisorySeverityWhy it's related
GHSA-673q-mjm6-r5xr
Next.js: Unauthenticated Remote Code Execution in `use cache` functions returning typed arrays
Critical Also affects next
GHSA-2464-fhr4-w9xw
Next.js: Unauthenticated Remote Code Execution in Image Optimization API when SVG files are used
Critical Also affects next
GHSA-p3m5-59mp-jv5r
Next.js: Denial of Service in App Router using Server Actions
High Also affects next
GHSA-3w37-wq28-93x7
Next.js: Pending `use cache` fill can leak Draft Mode content into regular responses and persisted pages
Medium Also affects next
GHSA-4jqv-mc3x-m676
Next.js has cache poisoning of SSG and ISR pages in self-hosted applications
Medium Also affects next
GHSA-39w2-rjm5-chcv
Next.js has information disclosure in development server's Model Context Protocol endpoint
Medium Also affects next
GHSA-f87g-xv8r-7p7x
Next.js has information disclosure in App Router metadata image routes via dynamicParams bypass
Medium Also affects next
GHSA-mcj8-r9mp-w47p
Next.js has cache poisoning in SSG/ISR rendering that leads to cross-user content substitution and persistent denial of service
Medium Also affects next
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor