GHSA-38j9-7pp9-2hjw BIT-vault-2021-32923 CVE-2021-32923 GO-2022-0623
Invalid session token expiration
- Severity
- 7.4 / 10
- High · CVSS 3.1
- Exploit chance (EPSS)
- 1.38%
- Chance of exploitation in the next 30 days. Higher than 72.07% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- CWE-613 Insufficient Session Expiration
- Fix
1.7.2- Upgrade github.com/hashicorp/vault to this version or later
Description
HashiCorp Vault and Vault Enterprise allowed the renewal of nearly-expired token leases and dynamic secret leases (specifically, those within 1 second of their maximum TTL), which caused them to be incorrectly treated as non-expiring during subsequent use. Fixed in 1.5.9, 1.6.5, and 1.7.2.
Affected versions
Go
| Package | Vulnerable | Fixed in |
|---|---|---|
| github.com/hashicorp/vault | >= 1.7.0, < 1.7.2 |
1.7.2 |
| github.com/hashicorp/vault | >= 1.6.0, < 1.6.5 |
1.6.5 |
| github.com/hashicorp/vault | >= 0.10.0, < 1.5.9 |
1.5.9 |
| github.com/hashicorp/vault | >= 0.10.0, < 1.5.9>= 1.6.0, < 1.6.5>= 1.7.0, < 1.7.2 |
1.5.91.6.51.7.2 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
github.com/hashicorp/vault Go → 1.7.2
- go
go get github.com/hashicorp/vault@v1.7.2 && go mod tidy
Severity breakdown
CVSS 3.1 7.4
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
- Attack vector
- Network
- Attack complexity
- High
- Privileges required
- None
- User interaction
- None
- Scope
- Unchanged
- Confidentiality
- High
- Integrity
- High
- Availability
- None
Weakness
CWE-613: Insufficient Session Expiration
According to WASC, "Insufficient Session Expiration is when a web site permits an attacker to reuse old session credentials or session IDs for authorization."
How to prevent it
- Implementation: Set sessions/credentials expiration date.
References
Advisories
Other links
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-88v5-9hxc-f85r HashiCorp Vault Vulnerable to Denial-of-Service via Unauthenticated Root Token Generation/Rekey Operations | High | Also affects github.com/hashicorp/vault |
| GHSA-8r5m-3f66-qpr3 HashiCorp Vault has Server-Side Request Forgery in ACME Challenge Validation via Attacker-Controlled DNS | High | Also affects github.com/hashicorp/vault |
| GHSA-72gw-fmmr-c4r4 HashiCorp Vault May Expose Tokens to Auth Plugins Due to Incorrect Header Sanitization | High | Also affects github.com/hashicorp/vault |
| GHSA-m2w4-8ggf-rj47 HashiCorp Vault has a KVv2 Metadata and Secret Deletion Policy Bypass that leads to Denial-of-Service | High | Also affects github.com/hashicorp/vault |
| GHSA-vp5w-xcfc-73wf Hashicorp Vault and Vault Enterprise vulnerable to a denial of service when processing JSON | High | Also affects github.com/hashicorp/vault |
| GHSA-9g4h-h484-3578 HashiCorp Vault and Vault Enterprise's AWS Auth method may be susceptible to authentication bypass | High | Also affects github.com/hashicorp/vault |
| GHSA-8f82-53h8-2p34 HashiCorp Vault Community Edition Denial of Service Though Complex JSON Payloads | High | Also affects github.com/hashicorp/vault |
| GHSA-7rx2-769v-hrwf HashiCorp Vault ldap auth method may not have correctly enforced MFA | High | Also affects github.com/hashicorp/vault |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor