GHSA-36vm-xw34-x4pj BIT-tensorflow-2021-29562 CVE-2021-29562 PYSEC-2021-199 PYSEC-2021-490 PYSEC-2021-688
CHECK-fail in `tf.raw_ops.IRFFT`
- Severity
- 0.0 / 10
- Low · CVSS 4.0
- Exploit chance (EPSS)
- 0.19%
- Chance of exploitation in the next 30 days. Higher than 8.57% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- CWE-617 Reachable Assertion
- Fix
- Available
- 3 packages have a fixed version
Description
Impact
An attacker can cause a denial of service by exploiting a CHECK-failure coming from the implementation of tf.raw_ops.IRFFT:
import tensorflow as tf
values = [-10.0] * 130
values[0] = -9.999999999999995
inputs = tf.constant(values, shape=[10, 13], dtype=tf.float32)
inputs = tf.cast(inputs, dtype=tf.complex64)
fft_length = tf.constant([0], shape=[1], dtype=tf.int32)
tf.raw_ops.IRFFT(input=inputs, fft_length=fft_length)
The above example causes Eigen code to operate on an empty matrix. This triggers on an assertion and causes program termination.
Patches
We have patched the issue in GitHub commit 1c56f53be0b722ca657cbc7df461ed676c8642a2.
The fix will be included in TensorFlow 2.5.0. We will also cherrypick this commit on TensorFlow 2.4.2, TensorFlow 2.3.3, TensorFlow 2.2.3 and TensorFlow 2.1.4, as these are also affected and still in supported range.
For more information
Please consult our security guide for more information regarding the security model and how to contact us with issues and questions.
Attribution
This vulnerability has been reported by Yakun Zhang and Ying Wang of Baidu X-Team.
Affected versions
PyPI
| Package | Vulnerable | Fixed in |
|---|---|---|
| tensorflow | < 2.1.4 |
2.1.4 |
| tensorflow | >= 2.2.0, < 2.2.3 |
2.2.3 |
| tensorflow | >= 2.3.0, < 2.3.3 |
2.3.3 |
| tensorflow | >= 2.4.0, < 2.4.2 |
2.4.2 |
| tensorflow | < 2.1.4>= 2.2.0, < 2.2.3>= 2.3.0, < 2.3.3>= 2.4.0, < 2.4.2 |
2.1.42.2.32.3.32.4.2 |
| tensorflow-cpu | < 2.1.4 |
2.1.4 |
| tensorflow-cpu | >= 2.2.0, < 2.2.3 |
2.2.3 |
| tensorflow-cpu | >= 2.3.0, < 2.3.3 |
2.3.3 |
| tensorflow-cpu | >= 2.4.0, < 2.4.2 |
2.4.2 |
| tensorflow-cpu | < 2.1.4>= 2.2.0, < 2.2.3>= 2.3.0, < 2.3.3>= 2.4.0, < 2.4.2 |
2.1.42.2.32.3.32.4.2 |
| tensorflow-gpu | < 2.1.4 |
2.1.4 |
| tensorflow-gpu | >= 2.2.0, < 2.2.3 |
2.2.3 |
| tensorflow-gpu | >= 2.3.0, < 2.3.3 |
2.3.3 |
| tensorflow-gpu | >= 2.4.0, < 2.4.2 |
2.4.2 |
| tensorflow-gpu | < 2.1.4>= 2.2.0, < 2.2.3>= 2.3.0, < 2.3.3>= 2.4.0, < 2.4.2 |
2.1.42.2.32.3.32.4.2 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
tensorflow PyPI → 2.1.4
- pip
pip install --upgrade "tensorflow>=2.1.4"- poetry
poetry add "tensorflow>=2.1.4"- uv
uv add "tensorflow>=2.1.4"
tensorflow-cpu PyPI → 2.1.4
- pip
pip install --upgrade "tensorflow-cpu>=2.1.4"- poetry
poetry add "tensorflow-cpu>=2.1.4"- uv
uv add "tensorflow-cpu>=2.1.4"
tensorflow-gpu PyPI → 2.1.4
- pip
pip install --upgrade "tensorflow-gpu>=2.1.4"- poetry
poetry add "tensorflow-gpu>=2.1.4"- uv
uv add "tensorflow-gpu>=2.1.4"
Severity breakdown
CVSS 4.0 0.0
CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N
- Attack vector
- Local
- Attack complexity
- Low
- Attack requirements
- Present
- Privileges required
- Low
- User interaction
- None
- Confidentiality (vulnerable system)
- None
- Integrity (vulnerable system)
- None
- Availability (vulnerable system)
- Low
- Confidentiality (subsequent systems)
- None
- Integrity (subsequent systems)
- None
- Availability (subsequent systems)
- None
CVSS 3.1 2.5
CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:N/I:N/A:L
- Attack vector
- Local
- Attack complexity
- High
- Privileges required
- Low
- User interaction
- None
- Scope
- Unchanged
- Confidentiality
- None
- Integrity
- None
- Availability
- Low
Weakness
CWE-617: Reachable Assertion
The product contains an assert() or similar statement that can be triggered by an attacker, which leads to an application exit or other behavior that is more severe than necessary.
How to prevent it
- Implementation: Make sensitive open/close operation non reachable by directly user-controlled data (e.g. open/close resources)
- Implementation: Perform input validation on user data.
References
Advisories
Packages
Other links
- github.com/tensorflow/tensorflow/security/advisories/GHSA-36vm-xw34-x4pj
- github.com/tensorflow/tensorflow/commit/1c56f53be0b722ca657cbc7df461ed676c8642a2
- github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2021-490…
- github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2021-688…
- github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-199.yaml
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-gjh7-xx4r-x345 TensorFlow has segfault in array_ops.upper_bound | High | Also affects tensorflow |
| GHSA-fxgc-95xx-grvq TensorFlow Denial of Service vulnerability | Medium | Also affects tensorflow |
| GHSA-93vr-9q9m-pj8p TensorFlow vulnerable to Out-of-Bounds Read in DynamicStitch | High | Also affects tensorflow |
| GHSA-qjqc-vqcf-5qvj TensorFlow vulnerable to seg fault in `tf.raw_ops.Print` | High | Also affects tensorflow |
| GHSA-7jvm-xxmr-v5cw TensorFlow vulnerable to integer overflow in EditDistance | High | Also affects tensorflow |
| GHSA-64jg-wjww-7c5w TensorFlow has Null Pointer Error in TensorArrayConcatV2 | High | Also affects tensorflow |
| GHSA-6hg6-5c2q-7rcr TensorFlow has Heap-buffer-overflow in AvgPoolGrad | High | Also affects tensorflow |
| GHSA-558h-mq8x-7q9g TensorFlow has Null Pointer Error in SparseSparseMaximum | High | Also affects tensorflow |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor