GHSA-3448-vrgh-85xr CVE-2019-14493 PYSEC-2026-2795 PYSEC-2026-2806 PYSEC-2026-2834 PYSEC-2026-718
NULL Pointer Dereference in OpenCV.
- Severity
- 7.5 / 10
- High · CVSS 3.0
- Exploit chance (EPSS)
- 3.31%
- Chance of exploitation in the next 30 days. Higher than 88.54% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- CWE-476 NULL Pointer Dereference
- Fix
- Available
- 4 packages have a fixed version
Description
An issue was discovered in OpenCV before 4.1.1 (OpenCV-Python before 4.1.1.26). There is a NULL pointer dereference in the function cv::XMLParser::parse at modules/core/src/persistence.cpp.
Affected versions
PyPI
| Package | Vulnerable | Fixed in |
|---|---|---|
| opencv-contrib-python | < 4.1.1.26 |
4.1.1.26 |
| opencv-contrib-python-headless | < 4.1.1.26 |
4.1.1.26 |
| opencv-contrib-python-headless | < 4.1.1.26 |
4.1.1.26 |
| opencv-python | < 4.1.1.26 |
4.1.1.26 |
| opencv-python | < 4.1.1.26 |
4.1.1.26 |
| opencv-python-headless | < 4.1.1.26 |
4.1.1.26 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
opencv-contrib-python PyPI → 4.1.1.26
- pip
pip install --upgrade "opencv-contrib-python>=4.1.1.26"- poetry
poetry add "opencv-contrib-python>=4.1.1.26"- uv
uv add "opencv-contrib-python>=4.1.1.26"
opencv-contrib-python-headless PyPI → 4.1.1.26
- pip
pip install --upgrade "opencv-contrib-python-headless>=4.1.1.26"- poetry
poetry add "opencv-contrib-python-headless>=4.1.1.26"- uv
uv add "opencv-contrib-python-headless>=4.1.1.26"
opencv-python PyPI → 4.1.1.26
- pip
pip install --upgrade "opencv-python>=4.1.1.26"- poetry
poetry add "opencv-python>=4.1.1.26"- uv
uv add "opencv-python>=4.1.1.26"
opencv-python-headless PyPI → 4.1.1.26
- pip
pip install --upgrade "opencv-python-headless>=4.1.1.26"- poetry
poetry add "opencv-python-headless>=4.1.1.26"- uv
uv add "opencv-python-headless>=4.1.1.26"
Severity breakdown
CVSS 3.0 7.5
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Attack vector
- Network
- Attack complexity
- Low
- Privileges required
- None
- User interaction
- None
- Scope
- Unchanged
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Weakness
CWE-476: NULL Pointer Dereference
The product dereferences a pointer that it expects to be valid but is NULL.
How to prevent it
- Implementation: For any pointers that could have been modified or provided from a function that can return NULL, check the pointer for NULL before use. When working with a multithreaded or otherwise asynchronous environment, ensure that proper locking APIs are used to lock before the check, and unlock when it has finished [REF-1484].
- Requirements: Select a programming language that is not susceptible to these issues.
- Implementation: Check the results of all functions that return a value and verify that the value is non-null before acting upon it.
- Architecture and Design: Identify all variables and data stores that receive information from external sources, and apply input validation to make sure that they are only initialized to expected values.
- Implementation: Explicitly initialize all variables and other data stores, either during declaration or just before the first usage.
References
Advisories
Packages
Other links
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| PYSEC-2023-183 opencv-python versions before v4.8.1.78 bundled libwebp binaries in wheels that are vulnerable to CVE-2023-4863. | High Known exploited | Also affects opencv-python |
| PYSEC-2023-181 opencv-contrib-python versions before v4.8.1.78 bundled libwebp binaries in wheels that are vulnerable to CVE-2023-4863. | High Known exploited | Also affects opencv-contrib-python |
| GHSA-qr4w-53vh-m672 opencv-python bundled libwebp binaries in wheels that are vulnerable to CVE-2023-4863 | High | Also affects opencv-python |
| GHSA-cxjf-x6jp-p7mc opencv-contrib-python bundled libwebp binaries in wheels that are vulnerable to CVE-2023-4863 | High | Also affects opencv-contrib-python |
| GHSA-9g8h-pjm4-q92p Out-of-bounds Write in OpenCV. | Medium | Also affects opencv-contrib-python |
| GHSA-q799-q27x-vp7w Out-of-bounds Write in OpenCV | High | Also affects opencv-contrib-python |
| GHSA-m6vm-8g8v-xfjh Out-of-bounds Write in OpenCV | High | Also affects opencv-contrib-python |
| GHSA-jggw-2q6g-c3m6 Out-of-bounds Read in OpenCV | Medium | Also affects opencv-contrib-python |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor