Skip to content

GHSA-337w-fxpq-5m34

Drupal core uses a vulnerable Third-party library CKEditor

Medium Packagist
Severity
4.2 / 10
Medium · CVSS 3.1
Exploit chance (EPSS)
—
No score published
Known exploited
No
Not in CISA's catalog
Weakness
—
Not classified
Fix
8.7.12
Upgrade drupal/drupal to this version or later

Description

The Drupal project uses the third-party library CKEditor, which has released a security improvement that is needed to protect some Drupal configurations.

Vulnerabilities are possible if Drupal is configured to use the WYSIWYG CKEditor for your site's users. An attacker that can create or edit content may be able to exploit this Cross Site Scripting (XSS) vulnerability to target users with access to the WYSIWYG CKEditor, and this may include site admins with privileged access.

The latest versions of Drupal update CKEditor to 4.14 to mitigate the vulnerabilities.

Affected versions

Packagist

PackageVulnerableFixed in
drupal/drupal
>= 8.0.0, < 8.7.12
8.7.12
drupal/drupal
>= 8.8.0, < 8.8.4
8.8.4

How to fix

Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.

drupal/drupal Packagist → 8.7.12

composer
composer require drupal/drupal:^8.7.12

Severity breakdown

CVSS 3.1 4.2

CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:N

Attack vector
Network
Attack complexity
High
Privileges required
None
User interaction
Required
Scope
Unchanged
Confidentiality
Low
Integrity
Low
Availability
None

References

Timeline

  1. Published
  2. Last updated by the source
AdvisorySeverityWhy it's related
CVE-2020-13671
Drupal core Unrestricted Upload of File with Dangerous Type
High Known exploited Also affects drupal/drupal
CVE-2019-6340
Drupal Core Remote Code Execution Vulnerability
High Known exploited Also affects drupal/drupal
CVE-2018-7602
Drupal Core Remote Code Execution Vulnerability
Critical Known exploited Also affects drupal/drupal
CVE-2018-7600
Drupal Core Remote Code Execution Vulnerability
Critical Known exploited Also affects drupal/drupal
DRUPAL-CORE-2024-008
Drupal core contains a potential PHP Object Injection vulnerability
Critical Also affects drupal/drupal
DRUPAL-CORE-2024-007
Drupal core contains a potential PHP Object Injection vulnerability
Critical Also affects drupal/drupal
DRUPAL-CORE-2024-006
Drupal core contains a potential PHP Object Injection vulnerability
Critical Also affects drupal/drupal
DRUPAL-CORE-2024-004
Drupal core Access bypass
High Also affects drupal/drupal
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor