GHSA-2xmj-8wmq-7475 CVE-2025-57756
Contao discloses sensitive information in the front end search index
- Severity
- 5.3 / 10
- Medium · CVSS 3.1
- Exploit chance (EPSS)
- 0.30%
- Chance of exploitation in the next 30 days. Higher than 22.38% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- CWE-200 Exposure of Sensitive Information to an Unauthorized Actor
- CWE-612 Improper Authorization of Index Containing Sensitive Information
- Fix
- Available
- 2 packages have a fixed version
Description
Impact
Protected content elements that are rendered as fragments are indexed and become publicly available in the front end search.
Patches
Update to Contao 4.13.56, 5.3.38 or 5.6.1.
Workarounds
Disable the front end search.
For more information
If you have any questions or comments about this advisory, open an issue in contao/contao.
Affected versions
Packagist
| Package | Vulnerable | Fixed in |
|---|---|---|
| contao/contao | >= 4.9.14, < 4.13.56 |
4.13.56 |
| contao/contao | >= 5.0.0-RC1, < 5.3.38 |
5.3.38 |
| contao/contao | >= 5.4.0-RC1, < 5.6.1 |
5.6.1 |
| contao/core-bundle | >= 4.9.14, < 4.13.56 |
4.13.56 |
| contao/core-bundle | >= 5.0.0-RC1, < 5.3.38 |
5.3.38 |
| contao/core-bundle | >= 5.4.0-RC1, < 5.6.1 |
5.6.1 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
contao/contao Packagist → 4.13.56
- composer
composer require contao/contao:^4.13.56
contao/core-bundle Packagist → 4.13.56
- composer
composer require contao/core-bundle:^4.13.56
Severity breakdown
CVSS 3.1 5.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- Attack vector
- Network
- Attack complexity
- Low
- Privileges required
- None
- User interaction
- None
- Scope
- Unchanged
- Confidentiality
- Low
- Integrity
- None
- Availability
- None
Weakness
CWE-200: Exposure of Sensitive Information to an Unauthorized Actor
The product exposes sensitive information to an actor that is not explicitly authorized to have access to that information.
How to prevent it
- Architecture and Design: Compartmentalize the system to have "safe" areas where trust boundaries can be unambiguously drawn. Do not allow sensitive data to go outside of the trust boundary and always be careful when interfacing with a compartment outside of the safe area. Ensure that appropriate compartmentalization is built into the system design, and the compartmentalization allows for and reinforces privilege separation functionality. Architects and designers should rely on the principle of least privilege to decide the appropriate time to use privileges and the time to drop privileges.
CWE-612: Improper Authorization of Index Containing Sensitive Information
The product creates a search index of private or sensitive documents, but it does not properly limit index access to actors who are authorized to see the original information.
References
Advisories
Packages
Other links
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-9ff2-p842-45wq Contao: Cross-site request forgery in custom backend actions | Low | Also affects contao/core-bundle |
| GHSA-q6wp-fr43-gm9v Contao: Improper access control in the preview links module | Medium | Also affects contao/core-bundle |
| GHSA-5974-gfqc-wrcm Contao: Improper access control in the table access voter | Medium | Also affects contao/core-bundle |
| GHSA-mrvp-7wmx-5m4h Contao: Path traversal in the images controller | Medium | Also affects contao/core-bundle |
| GHSA-mfxh-vp55-7gc6 Contao: The registration module re-sends activation mails | Medium | Also affects contao/core-bundle |
| GHSA-x2rp-9qf7-2fmq Contao: Protected page content is disclosed to anonymous visitors after contao.search.index_protected is disabled | Medium | Also affects contao/core-bundle |
| GHSA-grm4-wm43-9jh5 Contao: Possible path traversal in job download URIs | Low | Also affects contao/contao |
| GHSA-87mg-5grr-rhwh Contao: Server-Side Request Forgery (SSRF) via Unvalidated RSS Feed URL in Feed Reader Module | Low | Also affects contao/contao |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor