GHSA-2qrr-c2gh-pr35 CVE-2019-12474
Wikimedia information leak vulnerability
- Severity
- 7.5 / 10
- High · CVSS 3.0
- Exploit chance (EPSS)
- 2.04%
- Chance of exploitation in the next 30 days. Higher than 81.16% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- CWE-200 Exposure of Sensitive Information to an Unauthorized Actor
- Fix
1.27.6- Upgrade mediawiki/core to this version or later
Description
Wikimedia MediaWiki 1.23.0 through 1.32.1 has an information leak. Privileged API responses that include whether a recent change has been patrolled may be cached publicly. Fixed in 1.32.2, 1.31.2, 1.30.2 and 1.27.6.
Affected versions
Packagist
| Package | Vulnerable | Fixed in |
|---|---|---|
| mediawiki/core | >= 1.27.0, < 1.27.6 |
1.27.6 |
| mediawiki/core | >= 1.30.0, < 1.30.2 |
1.30.2 |
| mediawiki/core | >= 1.31.0, < 1.31.2 |
1.31.2 |
| mediawiki/core | >= 1.32.0, < 1.32.2 |
1.32.2 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
mediawiki/core Packagist → 1.27.6
- composer
composer require mediawiki/core:^1.27.6
Severity breakdown
CVSS 3.0 7.5
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- Attack vector
- Network
- Attack complexity
- Low
- Privileges required
- None
- User interaction
- None
- Scope
- Unchanged
- Confidentiality
- High
- Integrity
- None
- Availability
- None
Weakness
CWE-200: Exposure of Sensitive Information to an Unauthorized Actor
The product exposes sensitive information to an actor that is not explicitly authorized to have access to that information.
How to prevent it
- Architecture and Design: Compartmentalize the system to have "safe" areas where trust boundaries can be unambiguously drawn. Do not allow sensitive data to go outside of the trust boundary and always be careful when interfacing with a compartment outside of the safe area. Ensure that appropriate compartmentalization is built into the system design, and the compartmentalization allows for and reinforces privilege separation functionality. Architects and designers should rely on the principle of least privilege to decide the appropriate time to use privileges and the time to drop privileges.
References
Advisories
Packages
Other links
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-w5fx-cx7f-6vr9 MediaWiki Denial of Service vulnerability | High | Also affects mediawiki/core |
| GHSA-5vj8-g3qg-4qh6 X-Forwarded-For header allows brute-forcing autoblocked IP addresses | Critical | Also affects mediawiki/core |
| GHSA-c8wv-qwwc-6j73 MediaWiki allows a denial of service | Medium | Also affects mediawiki/core |
| GHSA-rqvj-fc2x-99q6 OATHAuth extension in MediaWiki is not implementing rate limit | High | Also affects mediawiki/core |
| GHSA-c4rj-wrmq-52rj MediaWiki Special:UserRights exposes the existence of hidden users | Medium | Also affects mediawiki/core |
| GHSA-h8qx-mj6v-2934 MediaWiki Cross-site Scripting (XSS) vulnerability | Medium | Also affects mediawiki/core |
| GHSA-4vr7-m8p8-434h MediaWiki Cross-site Scripting (XSS) vulnerability | Medium | Also affects mediawiki/core |
| GHSA-2f58-vf6g-6p8x MediaWiki Cross-site Scripting (XSS) vulnerability | Medium | Also affects mediawiki/core |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor