Skip to content

GHSA-2qmw-pvf7-4mw6 BIT-vault-2024-6468 CVE-2024-6468 GO-2024-2982

Hashicorp Vault vulnerable to Improper Check or Handling of Exceptional Conditions

High Go
Severity
7.5 / 10
High · CVSS 3.1
Exploit chance (EPSS)
0.49%
Chance of exploitation in the next 30 days. Higher than 42.21% of scored vulnerabilities.
Known exploited
No
Not in CISA's catalog
Weakness
CWE-703 Improper Check or Handling of Exceptional Conditions
Fix
1.15.12
Upgrade github.com/hashicorp/vault to this version or later

Description

Vault and Vault Enterprise did not properly handle requests originating from unauthorized IP addresses when the TCP listener option, proxy_protocol_behavior, was set to deny_unauthorized. When receiving a request from a source IP address that was not listed in proxy_protocol_authorized_addrs, the Vault API server would shut down and no longer respond to any HTTP requests, potentially resulting in denial of service.

While this bug also affected versions of Vault up to 1.17.1 and 1.16.5, a separate regression in those release series did not allow Vault operators to configure the deny_unauthorized option, thus not allowing the conditions for the denial of service to occur.

Fixed in Vault and Vault Enterprise 1.17.2, 1.16.6, and 1.15.12

Affected versions

Go

PackageVulnerableFixed in
github.com/hashicorp/vault
>= 1.10.0, < 1.15.12
1.15.12
github.com/hashicorp/vault
>= 1.16.0-rc1, < 1.16.3
1.16.3
github.com/hashicorp/vault
>= 1.17.0-rc1, < 1.17.2
1.17.2
github.com/hashicorp/vault
>= 1.10.0, < 1.16.3
>= 1.17.0-rc1, < 1.17.2
1.16.3
1.17.2

How to fix

Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.

github.com/hashicorp/vault Go → 1.15.12

go
go get github.com/hashicorp/vault@v1.15.12 && go mod tidy

Severity breakdown

CVSS 3.1 7.5

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Attack vector
Network
Attack complexity
Low
Privileges required
None
User interaction
None
Scope
Unchanged
Confidentiality
None
Integrity
None
Availability
High

Weakness

CWE-703: Improper Check or Handling of Exceptional Conditions

The product does not properly anticipate or handle exceptional conditions that rarely occur during normal operation of the product.

References

Timeline

  1. Published
  2. Last updated by the source
  3. Latest EPSS score
AdvisorySeverityWhy it's related
GHSA-88v5-9hxc-f85r
HashiCorp Vault Vulnerable to Denial-of-Service via Unauthenticated Root Token Generation/Rekey Operations
High Also affects github.com/hashicorp/vault
GHSA-8r5m-3f66-qpr3
HashiCorp Vault has Server-Side Request Forgery in ACME Challenge Validation via Attacker-Controlled DNS
High Also affects github.com/hashicorp/vault
GHSA-72gw-fmmr-c4r4
HashiCorp Vault May Expose Tokens to Auth Plugins Due to Incorrect Header Sanitization
High Also affects github.com/hashicorp/vault
GHSA-m2w4-8ggf-rj47
HashiCorp Vault has a KVv2 Metadata and Secret Deletion Policy Bypass that leads to Denial-of-Service
High Also affects github.com/hashicorp/vault
GHSA-vp5w-xcfc-73wf
Hashicorp Vault and Vault Enterprise vulnerable to a denial of service when processing JSON
High Also affects github.com/hashicorp/vault
GHSA-9g4h-h484-3578
HashiCorp Vault and Vault Enterprise's AWS Auth method may be susceptible to authentication bypass
High Also affects github.com/hashicorp/vault
GHSA-8f82-53h8-2p34
HashiCorp Vault Community Edition Denial of Service Though Complex JSON Payloads
High Also affects github.com/hashicorp/vault
GHSA-7rx2-769v-hrwf
HashiCorp Vault ldap auth method may not have correctly enforced MFA
High Also affects github.com/hashicorp/vault
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor