Skip to content

GHSA-2jhh-5xm2-j4gf CVE-2021-43415 GO-2022-0573

Improper Authentication in HashiCorp Nomad

High Go
Severity
8.8 / 10
High · CVSS 3.1
Exploit chance (EPSS)
1.22%
Chance of exploitation in the next 30 days. Higher than 68.58% of scored vulnerabilities.
Known exploited
No
Not in CISA's catalog
Weakness
CWE-287 Improper Authentication
Fix
1.0.14
Upgrade github.com/hashicorp/nomad to this version or later

Description

HashiCorp Nomad and Nomad Enterprise up to 1.0.13, 1.1.7, and 1.2.0, with the QEMU task driver enabled, allowed authenticated users with job submission capabilities to bypass the configured allowed image paths. Fixed in 1.0.14, 1.1.8, and 1.2.1.

Affected versions

Go

PackageVulnerableFixed in
github.com/hashicorp/nomad
< 1.0.14
1.0.14
github.com/hashicorp/nomad
>= 1.1.0, < 1.1.8
1.1.8
github.com/hashicorp/nomad
>= 1.2.0, < 1.2.1
1.2.1
github.com/hashicorp/nomad
< 1.0.14
>= 1.1.0, < 1.1.8
>= 1.2.0, < 1.2.1
1.0.14
1.1.8
1.2.1

How to fix

Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.

github.com/hashicorp/nomad Go → 1.0.14

go
go get github.com/hashicorp/nomad@v1.0.14 && go mod tidy

Severity breakdown

CVSS 3.1 8.8

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Attack vector
Network
Attack complexity
Low
Privileges required
Low
User interaction
None
Scope
Unchanged
Confidentiality
High
Integrity
High
Availability
High

Weakness

CWE-287: Improper Authentication

When an actor claims to have a given identity, the product does not prove or insufficiently proves that the claim is correct.

How to prevent it
  • Architecture and Design: Use an authentication framework or library such as the OWASP ESAPI Authentication feature.

References

Timeline

  1. Published
  2. Last updated by the source
  3. Latest EPSS score
AdvisorySeverityWhy it's related
GHSA-hx53-77qj-8663
HashiCorp Nomad vulnerable to a path traversal
High Also affects github.com/hashicorp/nomad
GHSA-3934-423w-4jq3
HashiCorp Nomad vulnerable to symlink attack
Medium Also affects github.com/hashicorp/nomad
GHSA-rx97-6c62-55mf
Hashicorp Nomad Incorrect Privilege Assignment vulnerability
High Also affects github.com/hashicorp/nomad
GHSA-c3q9-q986-vrwh
Nomad is vulnerable to unintentional exposure of the workload identity token and client secret token in audit logs
Medium Also affects github.com/hashicorp/nomad
GHSA-hr68-hvgv-xxqf
Hashicorp Nomad Incorrect Privilege Assignment vulnerability
Medium Also affects github.com/hashicorp/nomad
GHSA-2w5v-x29g-jw7j
Hashicorp Nomad Incorrect Authorization vulnerability
High Also affects github.com/hashicorp/nomad
GHSA-25qx-vfw2-fw8r
Nomad Vulnerable to Allocation Directory Escape On Non-Existing File Paths Through Archive Unpacking
Medium Also affects github.com/hashicorp/nomad
GHSA-5mqx-rpxv-mvxj
HashiCorp Nomad is vulnerable to path escape through archive unpacking during migration
High Also affects github.com/hashicorp/nomad
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor