GHSA-2j23-fwqm-mgwr CVE-2019-19687 PYSEC-2019-29
OpenStack Keystone Credential Leakage
- Severity
- 0.0 / 10
- High · CVSS 4.0
- Exploit chance (EPSS)
- 1.78%
- Chance of exploitation in the next 30 days. Higher than 78.25% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- CWE-522 Insufficiently Protected Credentials
- Fix
15.0.1- Upgrade keystone to this version or later
Description
OpenStack Keystone 15.0.0 and 16.0.0 is affected by Data Leakage in the list credentials API. Any user with a role on a project is able to list any credentials with the /v3/credentials API when enforce_scope is false. Users with a role on a project are able to view any other users' credentials, which could (for example) leak sign-on information for Time-based One Time Passwords (TOTP). Deployments with enforce_scope set to false are affected. (There will be a slight performance impact for the list credentials API once this issue is fixed.)
Affected versions
PyPI
| Package | Vulnerable | Fixed in |
|---|---|---|
| keystone | >= 15.0.0, < 15.0.1 |
15.0.1 |
| keystone | >= 16.0.0, < 16.0.1 |
16.0.1 |
| keystone | < 16.0.1 |
16.0.1 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
keystone PyPI → 15.0.1
- pip
pip install --upgrade "keystone>=15.0.1"- poetry
poetry add "keystone>=15.0.1"- uv
uv add "keystone>=15.0.1"
Severity breakdown
CVSS 4.0 0.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- Attack vector
- Network
- Attack complexity
- Low
- Attack requirements
- None
- Privileges required
- Low
- User interaction
- None
- Confidentiality (vulnerable system)
- High
- Integrity (vulnerable system)
- High
- Availability (vulnerable system)
- High
- Confidentiality (subsequent systems)
- None
- Integrity (subsequent systems)
- None
- Availability (subsequent systems)
- None
CVSS 3.1 8.8
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Attack vector
- Network
- Attack complexity
- Low
- Privileges required
- Low
- User interaction
- None
- Scope
- Unchanged
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Weakness
CWE-522: Insufficiently Protected Credentials
The product transmits or stores authentication credentials, but it uses an insecure method that is susceptible to unauthorized interception and/or retrieval.
How to prevent it
- Architecture and Design: Use an appropriate security mechanism to protect the credentials.
- Architecture and Design: Make appropriate use of cryptography to protect the credentials.
- Implementation: Use industry standards to protect the credentials (e.g. LDAP, keystore, etc.).
References
Advisories
Packages
Other links
- github.com/openstack/keystone/commit/17947516b0095c51da5cff94771247f2e7c44ee6
- github.com/openstack/keystone/commit/17c337dbdbfb9d548ad531c2ad0483c9bce5b98f
- github.com/openstack/keystone/commit/bd3f63787151183f4daa43578aa491856fefae5b
- usn.ubuntu.com/4262-1
- security.openstack.org/ossa/OSSA-2019-006.html
- review.opendev.org
- review.opendev.org
- review.opendev.org
- github.com/pypa/advisory-database/tree/main/vulns/keystone/PYSEC-2019-29.yaml
- git.openstack.org/cgit/openstack/keystone/commit
- git.openstack.org/cgit/openstack/keystone/commit
- git.openstack.org/cgit/openstack/keystone/commit
- bugzilla.redhat.com/show_bug.cgi
- bugs.launchpad.net/keystone/+bug/1855080
- access.redhat.com/errata/RHSA-2019:4358
- openwall.com/lists/oss-security/2019/12/11/8
- review.opendev.org
- review.opendev.org
- review.opendev.org
- usn.ubuntu.com/4262-1
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-whqr-fgm5-x77q OpenStack Keystone's federated token rescoping mechanism doesn't propagate the original token's expiry to the newly issued token | High | Also affects keystone |
| GHSA-q623-f4j4-p4xj OpenStack Keystone has an Incorrect Authorization issue | High | Also affects keystone |
| GHSA-2r23-2g6v-2m5f OpenStack Keystone has an Authorization Bypass | High | Also affects keystone |
| GHSA-8f8m-wrvr-wcvf OpenStack Keystone doesn't verify that the user supplied in the authentication request matches the owner of the application credential | High | Also affects keystone |
| GHSA-hhq2-3832-xxcv OpenStack Keystone has an Incorrect Authorization Issue | High | Also affects keystone |
| GHSA-pfx2-9x9m-7ghx OpenStack Keystone: LDAP identity backend does not convert enabled attribute to boolean | High | Also affects keystone |
| GHSA-4phw-6824-6cfp OpenStack Keystone: Restricted application credentials can create EC2 credentials | Medium | Also affects keystone |
| GHSA-hcqg-5g63-7j9h OpenStack Keystone allows /v3/ec2tokens or /v3/s3tokens request with valid AWS Signature to provide Keystone authorization. | High | Also affects keystone |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor