Skip to content

GHSA-27j5-4p9v-pp67 BIT-tensorflow-2021-37644 CVE-2021-37644 PYSEC-2021-266 PYSEC-2021-557 PYSEC-2021-755

`std::abort` raised from `TensorListReserve`

Medium PyPI
Severity
0.0 / 10
Medium · CVSS 4.0
Exploit chance (EPSS)
0.15%
Chance of exploitation in the next 30 days. Higher than 4.36% of scored vulnerabilities.
Known exploited
No
Not in CISA's catalog
Weakness
CWE-617 Reachable Assertion
Fix
Available
3 packages have a fixed version

Description

Impact

Providing a negative element to num_elements list argument of tf.raw_ops.TensorListReserve causes the runtime to abort the process due to reallocating a std::vector to have a negative number of elements:

import tensorflow as tf

tf.raw_ops.TensorListReserve(
  element_shape = tf.constant([1]),
  num_elements=tf.constant([-1]),
  element_dtype = tf.int32)

The implementation calls std::vector.resize() with the new size controlled by input given by the user, without checking that this input is valid.

Patches

We have patched the issue in GitHub commit 8a6e874437670045e6c7dc6154c7412b4a2135e2.

The fix will be included in TensorFlow 2.6.0. We will also cherrypick this commit on TensorFlow 2.5.1, TensorFlow 2.4.3, and TensorFlow 2.3.4, as these are also affected and still in supported range.

For more information

Please consult our security guide for more information regarding the security model and how to contact us with issues and questions.

Attribution

This vulnerability has been reported by members of the Aivul Team from Qihoo 360.

Affected versions

PyPI

PackageVulnerableFixed in
tensorflow
< 2.3.4
2.3.4
tensorflow
>= 2.4.0, < 2.4.3
2.4.3
tensorflow
>= 2.5.0, < 2.5.1
2.5.1
tensorflow
>= 2.3.0, < 2.3.4
>= 2.4.0, < 2.4.3
2.3.4
2.4.3
tensorflow-cpu
< 2.3.4
2.3.4
tensorflow-cpu
>= 2.4.0, < 2.4.3
2.4.3
tensorflow-cpu
>= 2.5.0, < 2.5.1
2.5.1
tensorflow-cpu
>= 2.3.0, < 2.3.4
>= 2.4.0, < 2.4.3
2.3.4
2.4.3
tensorflow-gpu
< 2.3.4
2.3.4
tensorflow-gpu
>= 2.4.0, < 2.4.3
2.4.3
tensorflow-gpu
>= 2.5.0, < 2.5.1
2.5.1
tensorflow-gpu
>= 2.3.0, < 2.3.4
>= 2.4.0, < 2.4.3
2.3.4
2.4.3

How to fix

Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.

tensorflow PyPI → 2.3.4

pip
pip install --upgrade "tensorflow>=2.3.4"
poetry
poetry add "tensorflow>=2.3.4"
uv
uv add "tensorflow>=2.3.4"

tensorflow-cpu PyPI → 2.3.4

pip
pip install --upgrade "tensorflow-cpu>=2.3.4"
poetry
poetry add "tensorflow-cpu>=2.3.4"
uv
uv add "tensorflow-cpu>=2.3.4"

tensorflow-gpu PyPI → 2.3.4

pip
pip install --upgrade "tensorflow-gpu>=2.3.4"
poetry
poetry add "tensorflow-gpu>=2.3.4"
uv
uv add "tensorflow-gpu>=2.3.4"

Severity breakdown

CVSS 4.0 0.0

CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Attack vector
Local
Attack complexity
Low
Attack requirements
Present
Privileges required
Low
User interaction
None
Confidentiality (vulnerable system)
None
Integrity (vulnerable system)
None
Availability (vulnerable system)
High
Confidentiality (subsequent systems)
None
Integrity (subsequent systems)
None
Availability (subsequent systems)
None

CVSS 3.1 5.5

CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

Attack vector
Local
Attack complexity
Low
Privileges required
Low
User interaction
None
Scope
Unchanged
Confidentiality
None
Integrity
None
Availability
High

Weakness

CWE-617: Reachable Assertion

The product contains an assert() or similar statement that can be triggered by an attacker, which leads to an application exit or other behavior that is more severe than necessary.

How to prevent it
  • Implementation: Make sensitive open/close operation non reachable by directly user-controlled data (e.g. open/close resources)
  • Implementation: Perform input validation on user data.

References

Timeline

  1. Published
  2. Last updated by the source
  3. Latest EPSS score
AdvisorySeverityWhy it's related
GHSA-gjh7-xx4r-x345
TensorFlow has segfault in array_ops.upper_bound
High Also affects tensorflow
GHSA-fxgc-95xx-grvq
TensorFlow Denial of Service vulnerability
Medium Also affects tensorflow
GHSA-93vr-9q9m-pj8p
TensorFlow vulnerable to Out-of-Bounds Read in DynamicStitch
High Also affects tensorflow
GHSA-qjqc-vqcf-5qvj
TensorFlow vulnerable to seg fault in `tf.raw_ops.Print`
High Also affects tensorflow
GHSA-7jvm-xxmr-v5cw
TensorFlow vulnerable to integer overflow in EditDistance
High Also affects tensorflow
GHSA-64jg-wjww-7c5w
TensorFlow has Null Pointer Error in TensorArrayConcatV2
High Also affects tensorflow
GHSA-6hg6-5c2q-7rcr
TensorFlow has Heap-buffer-overflow in AvgPoolGrad
High Also affects tensorflow
GHSA-558h-mq8x-7q9g
TensorFlow has Null Pointer Error in SparseSparseMaximum
High Also affects tensorflow
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor