Skip to content

GHSA-24x4-6qmh-88qg BIT-tensorflow-2022-23584 CVE-2022-23584 PYSEC-2022-148 PYSEC-2022-93 PYSEC-2026-3085

Use after free in `DecodePng` kernel

High PyPI
Severity
7.6 / 10
High · CVSS 3.1
Exploit chance (EPSS)
0.73%
Chance of exploitation in the next 30 days. Higher than 54.31% of scored vulnerabilities.
Known exploited
No
Not in CISA's catalog
Weakness
CWE-416 Use After Free
Fix
Available
3 packages have a fixed version

Description

Impact

A malicious user can cause a use after free behavior when decoding PNG images:

if (/* ... error conditions ... */) {
  png::CommonFreeDecode(&decode);
  OP_REQUIRES(context, false,
              errors::InvalidArgument("PNG size too large for int: ",
                                      decode.width, " by ", decode.height));
}   

After png::CommonFreeDecode(&decode) gets called, the values of decode.width and decode.height are in an unspecified state.

Patches

We have patched the issue in GitHub commit e746adbfcfee15e9cfdb391ff746c765b99bdf9b.

The fix will be included in TensorFlow 2.8.0. We will also cherrypick this commit on TensorFlow 2.7.1, TensorFlow 2.6.3, and TensorFlow 2.5.3, as these are also affected and still in supported range.

For more information

Please consult our security guide for more information regarding the security model and how to contact us with issues and questions.

Affected versions

PyPI

PackageVulnerableFixed in
tensorflow
< 2.5.3
2.5.3
tensorflow
>= 2.6.0, < 2.6.3
2.6.3
tensorflow
>= 2.7.0, < 2.7.1
2.7.1
tensorflow
< 2.5.3
>= 2.6.0, < 2.6.3
>= 2.7.0, < 2.7.1
2.5.3
2.6.3
2.7.1
tensorflow-cpu
< 2.5.3
2.5.3
tensorflow-cpu
>= 2.6.0, < 2.6.3
2.6.3
tensorflow-cpu
>= 2.7.0, < 2.7.1
2.7.1
tensorflow-cpu
< 2.5.3
>= 2.6.0, < 2.6.3
2.5.3
2.6.3
tensorflow-gpu
< 2.5.3
2.5.3
tensorflow-gpu
>= 2.6.0, < 2.6.3
2.6.3
tensorflow-gpu
>= 2.7.0, < 2.7.1
2.7.1
tensorflow-gpu
< 2.5.3
>= 2.6.0, < 2.6.3
2.5.3
2.6.3

How to fix

Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.

tensorflow PyPI → 2.5.3

pip
pip install --upgrade "tensorflow>=2.5.3"
poetry
poetry add "tensorflow>=2.5.3"
uv
uv add "tensorflow>=2.5.3"

tensorflow-cpu PyPI → 2.5.3

pip
pip install --upgrade "tensorflow-cpu>=2.5.3"
poetry
poetry add "tensorflow-cpu>=2.5.3"
uv
uv add "tensorflow-cpu>=2.5.3"

tensorflow-gpu PyPI → 2.5.3

pip
pip install --upgrade "tensorflow-gpu>=2.5.3"
poetry
poetry add "tensorflow-gpu>=2.5.3"
uv
uv add "tensorflow-gpu>=2.5.3"

Severity breakdown

CVSS 3.1 7.6

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:H

Attack vector
Network
Attack complexity
Low
Privileges required
Low
User interaction
None
Scope
Unchanged
Confidentiality
Low
Integrity
Low
Availability
High

Weakness

CWE-416: Use After Free

The product reuses or references memory after it has been freed. At some point afterward, the memory may be allocated again and saved in another pointer, while the original pointer references a location somewhere within the new allocation. Any operations using the original pointer are no longer valid because the memory "belongs" to the code that operates on the new pointer.

How to prevent it
  • Architecture and Design: Choose a language that provides automatic memory management.
  • Implementation: When freeing pointers, be sure to set them to NULL once they are freed. However, the utilization of multiple or complex data structures may lower the usefulness of this strategy.

References

Timeline

  1. Published
  2. Last updated by the source
  3. Latest EPSS score
AdvisorySeverityWhy it's related
GHSA-gjh7-xx4r-x345
TensorFlow has segfault in array_ops.upper_bound
High Also affects tensorflow
GHSA-fxgc-95xx-grvq
TensorFlow Denial of Service vulnerability
Medium Also affects tensorflow
GHSA-93vr-9q9m-pj8p
TensorFlow vulnerable to Out-of-Bounds Read in DynamicStitch
High Also affects tensorflow
GHSA-qjqc-vqcf-5qvj
TensorFlow vulnerable to seg fault in `tf.raw_ops.Print`
High Also affects tensorflow
GHSA-7jvm-xxmr-v5cw
TensorFlow vulnerable to integer overflow in EditDistance
High Also affects tensorflow
GHSA-64jg-wjww-7c5w
TensorFlow has Null Pointer Error in TensorArrayConcatV2
High Also affects tensorflow
GHSA-6hg6-5c2q-7rcr
TensorFlow has Heap-buffer-overflow in AvgPoolGrad
High Also affects tensorflow
GHSA-558h-mq8x-7q9g
TensorFlow has Null Pointer Error in SparseSparseMaximum
High Also affects tensorflow
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor