GHSA-2475-53vw-vp25 BIT-tensorflow-2022-35968 CVE-2022-35968 PYSEC-2026-3083 PYSEC-2026-3263 PYSEC-2026-940
TensorFlow vulnerable to `CHECK` fail in `AvgPoolGrad`
- Severity
- 5.9 / 10
- Medium · CVSS 3.1
- Exploit chance (EPSS)
- 0.48%
- Chance of exploitation in the next 30 days. Higher than 41.24% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- CWE-617 Reachable Assertion
- Fix
- Available
- 3 packages have a fixed version
Description
Impact
The implementation of AvgPoolGrad does not fully validate the input orig_input_shape. This results in a CHECK failure which can be used to trigger a denial of service attack:
import tensorflow as tf
ksize = [1, 2, 2, 1]
strides = [1, 2, 2, 1]
padding = "VALID"
data_format = "NHWC"
orig_input_shape = tf.constant(-536870912, shape=[4], dtype=tf.int32)
grad = tf.constant(.0890338004362538, shape=[1,5,7,1], dtype=tf.float64)
tf.raw_ops.AvgPoolGrad(orig_input_shape=orig_input_shape, grad=grad, ksize=ksize, strides=strides, padding=padding, data_format=data_format)
Patches
We have patched the issue in GitHub commit 3a6ac52664c6c095aa2b114e742b0aa17fdce78f.
The fix will be included in TensorFlow 2.10.0. We will also cherrypick this commit on TensorFlow 2.9.1, TensorFlow 2.8.1, and TensorFlow 2.7.2, as these are also affected and still in supported range.
For more information
Please consult our security guide for more information regarding the security model and how to contact us with issues and questions.
Attribution
This vulnerability has been reported by Neophytos Christou, Secure Systems Labs, Brown University.
Affected versions
PyPI
| Package | Vulnerable | Fixed in |
|---|---|---|
| tensorflow | < 2.7.2 |
2.7.2 |
| tensorflow | >= 2.8.0, < 2.8.1 |
2.8.1 |
| tensorflow | >= 2.9.0, < 2.9.1 |
2.9.1 |
| tensorflow | < 2.7.2>= 2.8.0, < 2.8.1>= 2.9.0, < 2.9.1 |
2.7.22.8.12.9.1 |
| tensorflow-cpu | < 2.7.2 |
2.7.2 |
| tensorflow-cpu | >= 2.8.0, < 2.8.1 |
2.8.1 |
| tensorflow-cpu | >= 2.9.0, < 2.9.1 |
2.9.1 |
| tensorflow-cpu | < 2.7.2>= 2.8.0, < 2.8.1>= 2.9.0, < 2.9.1 |
2.7.22.8.12.9.1 |
| tensorflow-gpu | < 2.7.2 |
2.7.2 |
| tensorflow-gpu | >= 2.8.0, < 2.8.1 |
2.8.1 |
| tensorflow-gpu | >= 2.9.0, < 2.9.1 |
2.9.1 |
| tensorflow-gpu | < 2.7.2>= 2.8.0, < 2.8.1>= 2.9.0, < 2.9.1 |
2.7.22.8.12.9.1 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
tensorflow PyPI → 2.7.2
- pip
pip install --upgrade "tensorflow>=2.7.2"- poetry
poetry add "tensorflow>=2.7.2"- uv
uv add "tensorflow>=2.7.2"
tensorflow-cpu PyPI → 2.7.2
- pip
pip install --upgrade "tensorflow-cpu>=2.7.2"- poetry
poetry add "tensorflow-cpu>=2.7.2"- uv
uv add "tensorflow-cpu>=2.7.2"
tensorflow-gpu PyPI → 2.7.2
- pip
pip install --upgrade "tensorflow-gpu>=2.7.2"- poetry
poetry add "tensorflow-gpu>=2.7.2"- uv
uv add "tensorflow-gpu>=2.7.2"
Severity breakdown
CVSS 3.1 5.9
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
- Attack vector
- Network
- Attack complexity
- High
- Privileges required
- None
- User interaction
- None
- Scope
- Unchanged
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Weakness
CWE-617: Reachable Assertion
The product contains an assert() or similar statement that can be triggered by an attacker, which leads to an application exit or other behavior that is more severe than necessary.
How to prevent it
- Implementation: Make sensitive open/close operation non reachable by directly user-controlled data (e.g. open/close resources)
- Implementation: Perform input validation on user data.
References
Advisories
Packages
Other links
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-gjh7-xx4r-x345 TensorFlow has segfault in array_ops.upper_bound | High | Also affects tensorflow |
| GHSA-fxgc-95xx-grvq TensorFlow Denial of Service vulnerability | Medium | Also affects tensorflow |
| GHSA-93vr-9q9m-pj8p TensorFlow vulnerable to Out-of-Bounds Read in DynamicStitch | High | Also affects tensorflow |
| GHSA-qjqc-vqcf-5qvj TensorFlow vulnerable to seg fault in `tf.raw_ops.Print` | High | Also affects tensorflow |
| GHSA-7jvm-xxmr-v5cw TensorFlow vulnerable to integer overflow in EditDistance | High | Also affects tensorflow |
| GHSA-64jg-wjww-7c5w TensorFlow has Null Pointer Error in TensorArrayConcatV2 | High | Also affects tensorflow |
| GHSA-6hg6-5c2q-7rcr TensorFlow has Heap-buffer-overflow in AvgPoolGrad | High | Also affects tensorflow |
| GHSA-558h-mq8x-7q9g TensorFlow has Null Pointer Error in SparseSparseMaximum | High | Also affects tensorflow |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor