Skip to content

GHSA-23hm-7w47-xw72 BIT-tensorflow-2022-21726 CVE-2022-21726 PYSEC-2022-105 PYSEC-2022-50 PYSEC-2026-3082

Out of bounds read in Tensorflow

High PyPI
Severity
0.0 / 10
High · CVSS 4.0
Exploit chance (EPSS)
0.83%
Chance of exploitation in the next 30 days. Higher than 57.40% of scored vulnerabilities.
Known exploited
No
Not in CISA's catalog
Weakness
CWE-125 Out-of-bounds Read
Fix
Available
3 packages have a fixed version

Description

Impact

The implementation of Dequantize does not fully validate the value of axis and can result in heap OOB accesses:

import tensorflow as tf

@tf.function
def test():
  y = tf.raw_ops.Dequantize(
    input=tf.constant([1,1],dtype=tf.qint32),
    min_range=[1.0],
    max_range=[10.0],
    mode='MIN_COMBINED',
    narrow_range=False,
    axis=2**31-1,
    dtype=tf.bfloat16)
  return y

test()

The axis argument can be -1 (the default value for the optional argument) or any other positive value at most the number of dimensions of the input. Unfortunately, the upper bound is not checked and this results in reading past the end of the array containing the dimensions of the input tensor:

  if (axis_ > -1) {
    num_slices = input.dim_size(axis_);
  }
  // ...
  int64_t pre_dim = 1, post_dim = 1;
  for (int i = 0; i < axis_; ++i) {
    pre_dim *= float_output.dim_size(i);
  }
  for (int i = axis_ + 1; i < float_output.dims(); ++i) {
    post_dim *= float_output.dim_size(i);
  }

Patches

We have patched the issue in GitHub commit 23968a8bf65b009120c43b5ebcceaf52dbc9e943.

The fix will be included in TensorFlow 2.8.0. We will also cherrypick this commit on TensorFlow 2.7.1, TensorFlow 2.6.3, and TensorFlow 2.5.3, as these are also affected and still in supported range.

For more information

Please consult our security guide for more information regarding the security model and how to contact us with issues and questions.

Attribution

This vulnerability has been reported by Yu Tian of Qihoo 360 AIVul Team.

Affected versions

PyPI

PackageVulnerableFixed in
tensorflow
< 2.5.3
2.5.3
tensorflow
>= 2.6.0, < 2.6.3
2.6.3
tensorflow
>= 2.7.0, < 2.7.1
2.7.1
tensorflow
< 2.5.3
>= 2.6.0, < 2.6.3
>= 2.7.0, < 2.7.1
2.5.3
2.6.3
2.7.1
tensorflow-cpu
< 2.5.3
2.5.3
tensorflow-cpu
>= 2.6.0, < 2.6.3
2.6.3
tensorflow-cpu
>= 2.7.0, < 2.7.1
2.7.1
tensorflow-cpu
< 2.5.3
>= 2.6.0, < 2.6.3
2.5.3
2.6.3
tensorflow-gpu
< 2.5.3
2.5.3
tensorflow-gpu
>= 2.6.0, < 2.6.3
2.6.3
tensorflow-gpu
>= 2.7.0, < 2.7.1
2.7.1
tensorflow-gpu
< 2.5.3
>= 2.6.0, < 2.6.3
2.5.3
2.6.3

How to fix

Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.

tensorflow PyPI → 2.5.3

pip
pip install --upgrade "tensorflow>=2.5.3"
poetry
poetry add "tensorflow>=2.5.3"
uv
uv add "tensorflow>=2.5.3"

tensorflow-cpu PyPI → 2.5.3

pip
pip install --upgrade "tensorflow-cpu>=2.5.3"
poetry
poetry add "tensorflow-cpu>=2.5.3"
uv
uv add "tensorflow-cpu>=2.5.3"

tensorflow-gpu PyPI → 2.5.3

pip
pip install --upgrade "tensorflow-gpu>=2.5.3"
poetry
poetry add "tensorflow-gpu>=2.5.3"
uv
uv add "tensorflow-gpu>=2.5.3"

Severity breakdown

CVSS 4.0 0.0

CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:H/SC:N/SI:N/SA:N

Attack vector
Network
Attack complexity
Low
Attack requirements
None
Privileges required
Low
User interaction
None
Confidentiality (vulnerable system)
High
Integrity (vulnerable system)
None
Availability (vulnerable system)
High
Confidentiality (subsequent systems)
None
Integrity (subsequent systems)
None
Availability (subsequent systems)
None

CVSS 3.1 8.1

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:H

Attack vector
Network
Attack complexity
Low
Privileges required
Low
User interaction
None
Scope
Unchanged
Confidentiality
High
Integrity
None
Availability
High

Weakness

CWE-125: Out-of-bounds Read

The product reads data past the end, or before the beginning, of the intended buffer.

How to prevent it
  • Implementation: Assume all input is malicious. Use an "accept known good" input validation strategy, i.e., use a list of acceptable inputs that strictly conform to specifications. Reject any input that does not strictly conform to specifications, or transform it into something that does. When performing input validation, consider all potentially relevant properties, including length, type of input, the full range of acceptable values, missing or extra inputs, syntax, consistency across related fields, and conformance to business rules. As an example of business rule logic, "boat" may be syntactically valid because it only contains alphanumeric characters, but it is not valid if the input is only expected to contain colors such as "red" or "blue." Do not rely exclusively on looking for malicious or malformed inputs. This is likely to miss at least one undesirable input, especially if the code's environment changes. This can give attackers enough room to bypass the intended validation. However, denylists can be useful for detecting potential attacks or determining which inputs are so malformed that they should be rejected outright. To reduce the likelihood of introducing an out-of-bounds read, ensure that you validate and ensure correct calculations for any length argument, buffer size calculation, or offset. Be especially careful of relying on a sentinel (i.e. special character such as NUL) in untrusted inputs.
  • Architecture and Design: Use a language that provides appropriate memory abstractions.

References

Timeline

  1. Published
  2. Last updated by the source
  3. Latest EPSS score
AdvisorySeverityWhy it's related
GHSA-gjh7-xx4r-x345
TensorFlow has segfault in array_ops.upper_bound
High Also affects tensorflow
GHSA-fxgc-95xx-grvq
TensorFlow Denial of Service vulnerability
Medium Also affects tensorflow
GHSA-93vr-9q9m-pj8p
TensorFlow vulnerable to Out-of-Bounds Read in DynamicStitch
High Also affects tensorflow
GHSA-qjqc-vqcf-5qvj
TensorFlow vulnerable to seg fault in `tf.raw_ops.Print`
High Also affects tensorflow
GHSA-7jvm-xxmr-v5cw
TensorFlow vulnerable to integer overflow in EditDistance
High Also affects tensorflow
GHSA-64jg-wjww-7c5w
TensorFlow has Null Pointer Error in TensorArrayConcatV2
High Also affects tensorflow
GHSA-6hg6-5c2q-7rcr
TensorFlow has Heap-buffer-overflow in AvgPoolGrad
High Also affects tensorflow
GHSA-558h-mq8x-7q9g
TensorFlow has Null Pointer Error in SparseSparseMaximum
High Also affects tensorflow
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor