CVE-2024-45195
Apache OFBiz: Confused controller-view authorization logic (forced browsing)
High
Known exploited
- Severity
- 9.8 / 10
- High · CVSS 3.1
- Exploit chance (EPSS)
- 99.98%
- Chance of exploitation in the next 30 days. Higher than 99.98% of scored vulnerabilities.
- Known exploited
- Yes
- In CISA's catalog since Feb 4, 2025
- Weakness
- CWE-425 Direct Request ('Forced Browsing')
- Fix
- None yet
- No fixed version published
Exploited in the wild. Apache OFBiz Forced Browsing Vulnerability (Apache OFBiz). Required action: Apply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable. Due for U.S. federal agencies by Feb 25, 2025.
Description
Direct Request ('Forced Browsing') vulnerability in Apache OFBiz.
This issue affects Apache OFBiz: before 18.12.16.
Users are recommended to upgrade to version 18.12.16, which fixes the issue.
How to fix
No fixed version has been published yet. Until one is, remove or replace the package, or turn off or isolate the affected feature. This page updates when a fix ships.
Severity breakdown
CVSS 3.1 9.8
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Attack vector
- Network
- Attack complexity
- Low
- Privileges required
- None
- User interaction
- None
- Scope
- Unchanged
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Weakness
CWE-425: Direct Request ('Forced Browsing')
The web application does not adequately enforce appropriate authorization on all restricted URLs, scripts, or files.
How to prevent it
- Architecture and Design, Operation: Apply appropriate access control authorizations for each access to all restricted URLs, scripts or files.
- Architecture and Design: Consider using MVC based frameworks such as Struts.
References
Advisories
Fixes and patches
Issue reports
Other links
Timeline
- Published
- Added to CISA's Known Exploited Vulnerabilities catalog
- Remediation due for U.S. federal agencies
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-46xh-7854-f568 Concrete CMS is vulnerable to authorization bypass in the Calendar Block | Medium | Same weakness, CWE-425 |
| GHSA-hm32-hfmw-rhvg Keycloak has a Forced Browsing issue | Medium | Same weakness, CWE-425 |
| GHSA-53mr-6c8q-9789 LiteLLM: Privilege escalation via unrestricted proxy configuration endpoint | High | Same weakness, CWE-425 |
| GHSA-g6pg-52vf-843h MLFlow allows Tracing + Assessments Access | High | Same weakness, CWE-425 |
| GHSA-jxxm-27vp-c3m5 NATS allows MQTT clients to bypass ACL checks | Medium | Same weakness, CWE-425 |
| GO-2026-4601 Incorrect parsing of IPv6 host literals in net/url | High | Same weakness, CWE-425 |
| GHSA-h3vp-qwmx-5j25 Grokability Snipe-IT has incorrect authorization for accessing asset information | Low | Same weakness, CWE-425 |
| GHSA-x5w2-wcr8-9q45 Silverstripe Missing security check on dev/build/defaults | Medium | Same weakness, CWE-425 |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor